Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Removing Authentication prompts when clicking on a Document

  Asked By: Madhavi    Date: Feb 07    Category: Sharepoint    Views: 2277

We have WSS V3 (Not MOSS 2007) deployed in an internet environment
using SSL (and Host Headers, it works after editing the IIS metabase
and assigning a specific IP to the 443 SSL binding).

All that works fine, we get an authentication prompt where we put in
our domain credentials and get into the site.

What I am looking for and was told this would be a feature of in WSS
V3 is a way to remove the multiple authetnication prompts that occurs
when you click on documents in a document library.

Now I know WHY this happens (you don't want to pass security
credentials from one application to another as it's a big security
risk). But I was told that there should be a way to remove these
unneccesary authentication prompts using Office 2007 and WSS V3
possibly by using Forms Authentication where the cookie is shared
between applications?

So my question is this. What are all of the ways to remove this
authentication prompt so users only have to authenticate once. Also
another thing we hope to do is keep windows authentication for all of
the internal employees, but it would be okay if all the internet
users would have to start using Forms authentication if that is the
way to do it.

Or am I missing some setting some where in a .config file, in central
admin, or in Office 2007 that would remove my authentication issues?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Harihar Sonnad     Answered On: Feb 07

Using Forms will CAUSE this problem, not prevent it. Office applications don't
have any facility for reading forms cookies or understanding them at all.

The only way I know of to prevent this is to use NTLM authentication  and put
your web servers in the "Trusted" or "Intranet" zone. That way IE and Office
know it's okay to pass your credentials to them. That setting is configurable
in Tools -> Internet options in IE.

That will work for internal folks. External folks are out of luck, as they
aren't logged into their machines with an account that your server knows. I
think they're going to get prompted by Office apps regardless.

 
Answer #2    Answered By: Deven Gajjar     Answered On: Feb 07

What i'm getting, on a sort of related item, is, if i use Kerberos,
people are forced to enter their credentials - bizarrely, everyone but
me !

Mine just logs me straight in - I've tried putting in trusted sites and
clicking to say auto pass through logon and password but no difference

If you have any pointers where I can look at where to start looking for
this - I imagine its just an ie setting but it proving elusive for me at
the moment

 
Answer #3    Answered By: Latisha Schneider     Answered On: Feb 07

Did you install the software while logged in as yourself?

 
Answer #4    Answered By: Nora Maxwell     Answered On: Feb 07

Nope - i installed as the app pool account.