Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Read-only access will not let users Read

  Asked By: Jayshree    Date: Sep 20    Category: Sharepoint    Views: 2972

We are running: SP2003, SP2.

Both issues are when a group is assigned Read-Only rights.

I have never run into this before now but when a person clicks on a
link to open a document and the docuement link starts with "FILE://"
the link will display only a blank page. If you change the link to
start with "HTTP://" the file opens and displays fine.

Also, ran into another issue with Read-Only rights, users can not
open a document in a docuement library using the Sharepoint
Explorer View. It gives an access denied error. If I change the
Sharepoint view to All Documents or create my own, Read-Only works.
Just something specific to the SP Explorer View?

Has anyone heard of these things before? If I switch the rights to
Conributer, it all works fine, but that is too much access. I have
fixed all the links to HTTP:// and changed the view, so the issues
are resolved but I am wondering why this is.



7 Answers Found

Answer #1    Answered By: Tiana Whitaker     Answered On: Sep 20

We ran into a similar issue  with a file-based repository. I assume that
your links  are pointing to files on the file  system, not to documents
stored within the SharePoint database - is that correct? Are these MS
Word documents?

If the answer is yes to both, then this may apply to you. What we
determined with our file-based system was that when a MS Word file is
NOT marked with the read-only  ATTRIBUTE on the file system, and the user
HAS NTFS read  and does NOT have NTFS MODIFY permissions on the
containing folder, Word would look only at whether the Read-Only
ATTRIBUTE was set on the document  to determine whether is should open  a
recovery copy of the document. If the document was not marked with the
read-only ATTRIBUTE, Word would open the document for editing and
attempt to create  a recovery copy. If the user did not have rights  to
write to the containing folder, the creation of the recovery copy would
fail and Word would generate an error.

I haven't tried this inside the SharePoint environment yet, but I
suspect that it may cause unexpected behaviour. (Thanks for reminding me
- I have to test this...)

Answer #2    Answered By: Alice Chandler     Answered On: Sep 20

The links  are pointing to documents  kept in a SP document  library on
the same site. The documents are most PDF's, mixed with a few word
and excel. These documents were copied from a network file  share
into Sharepoint using the Explorer to SP Explorer copy and paste

Answer #3    Answered By: Lynette Sawyer     Answered On: Sep 20

Do you get the same behaviour with all three types?

Answer #4    Answered By: Alisha Itagi     Answered On: Sep 20

When we link  directly to the document  yes. But when using the SP
Explorer view, Word and Excel documents open  just fine, PDF's give
the error.

Answer #5    Answered By: Gretchen Stokes     Answered On: Sep 20

Oh - that's opposite to what I thought you might say. I'm stumped.

Answer #6    Answered By: Angarika Shroff     Answered On: Sep 20

I know - very bizarre. Like I said in my original posting, I
changed all the links  to HTTP:// and then made a custom view  for the
document libraries, so it is working. It just caused me a lot of
extra work and testing. I'll give it a few days to see if anyone
else has ideas, if not, I will give Microsoft support a call.

Answer #7    Answered By: Eliza Hutchinson     Answered On: Sep 20

If I remember correctly, we had to provide users  with the Browse
Directory rights  in order to allow users to perform some actions in
the Explorer view. Have you tried adding this right to the read  only

Didn't find what you were looking for? Find more on Read-only access will not let users Read Or get search suggestion and latest updates.