MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Publishing Site Template

  Asked By: Vikat    Date: Jun 18    Category: MOSS    Views: 810

For some reason, it looks like my collaboration site template is corrupted. Is
there anyway I can fix this? Is it possible for me to replace the template from
one MOSS server to another MOSS server? Where does the template reside in the 12



6 Answers Found

Answer #1    Answered By: Marc Dixon     Answered On: Jun 18

Collaboration template  uses:


It also references numerous features, including:

Most, if not all, publishing  features

If you can narrow it down, you can copy a good file over the bad, then IISRESET.

What are the symptoms that led you to believe the template is corrupted?

Answer #2    Answered By: Johathan Mcgowan     Answered On: Jun 18

After the site  comes up, the tabs I see are Home and Error. I do not see the
standard tabs that comes with the collaboration  template. I deleted the site
collection and recreated it and got the same result.

Initially I did a restore from one site collection to another site collection
(different domains) and I had some problems with modifying the navigation. I was
not able to modify the navigation on the new server. Whenever I made a change,
it kept going back to the tabs that was at the old site collection. So I went
ahead and deleted the site collection and this is when I started getting the
Error tab. The weird thing is that after I created a new site collection and got
the Error tab, I went into the navigation and noticed the tabs from the old site
collection were there.

Do you happen to know why the navigation was acting that way?

Answer #3    Answered By: Georgia Barr     Answered On: Jun 18

The last time I saw that happen was when someone took an existing
Publishing site  and saved it as a template  by manually navigating to the
Save as Site Template page. It would appear to work, but when you tried
to create a new site off the template it would leave this kind of half
built site. Sites built from the publishing  site definitions are
actually a set of sites. I suspect you deleted some but not all. You
will probably need to start your restore over.

Answer #4    Answered By: Jessi Sweet     Answered On: Jun 18

I've tried restoring multiple times and I still keep getting the Error tab. Do I
need to recreate the web application or can I just copy another collaboration
template from another server  onto this server? If that works, what files do I
need to copy over? Would it be the ones that Craig recommended below?

Answer #5    Answered By: Kelvin Mckinney     Answered On: Jun 18

If you are restoring a backup, then the template  has nothing to do with
the problem. Are you restoring to the same relative location in a web
application? For example if you backed it up from the root you need to
restore to the root.

Answer #6    Answered By: Gaurav Ghosh     Answered On: Jun 18

I guess this might be the problem. My original site  collection has this URL:
http://servernameA/sites/sitecollectionA. When I restored it onto my new server,
I restored it to the root that has this URL: http://servernameB. Does this make
a difference?

Didn't find what you were looking for? Find more on Publishing Site Template Or get search suggestion and latest updates.