MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Publishing Infrastructure feature error

  Asked By: Anushka    Date: Jan 08    Category: MOSS    Views: 2659

I am trying to create Publishing site from browser interface and it is
asking me to enable to Publishing Infrastructure feature and when I try to
enable this feature it ask me to enable more items. Please help me out.

How do we create publishing portal server?



9 Answers Found

Answer #1    Answered By: Alisha Itagi     Answered On: Jan 08

Make sure that you enable  the feature  within the web aplication, as well as the
site collection. This can be a little confusing at times. Also, make sure
you've enabled Enterprise features at the farm level.

Answer #2    Answered By: Faith Delgado     Answered On: Jan 08

I don't' see enterprise feature  under site  features. How do we get this
feature available under site features?

Answer #3    Answered By: Kristy Hicks     Answered On: Jan 08

The easiest way to do this would be to use one of the MOSS site  templates
that already have the publishing  features enabled. For example the
Publishing Site or Publishing Site with Workflow. These are on the
Publishing Tab when creating a site.

If you want to add Publishing to an existing site you need to activate the
Publishing Infrastructure feature  in the Site Collection Features first and
then the Publishing Feature in the Site Feature for the site. I've done
this on several sites and these are the only two features required but they
must be activated in this order.

Answer #4    Answered By: Amanda Brown     Answered On: Jan 08

When you installed MOSS, what was the product key you used? Standard
or Enterprise? Perhaps this is Enterprise features?

Answer #5    Answered By: Caleb Gordon     Answered On: Jan 08

This feature  is available in both Standard and Enterprise. Its just not
available in regular non-MOSS WSS.

Answer #6    Answered By: Anuj Lakhe     Answered On: Jan 08

I believed you enable  this feature  to all existing sites in Central
Admin/Operations, correct?

Answer #7    Answered By: Micheal Knight     Answered On: Jan 08

Nope. publishing  Infrastructure is activated in site  collection
Features in the Site Settings page of the top level web of the site
collection. Then Publishing is enabled in the Site Features of the
website where you wish to use publishing. There is not particular
feature related to this that is activated or visible in the Farm or Web
Application Features in Central Administration.

Answer #8    Answered By: Aditiya Kapale     Answered On: Jan 08

We are marketing dept and do have access to the server  but not sure if we
have all access so whenever I try to activate this feature  under site
features it says "One or more features must be turned on before this feature
can be activated".

I am not sure what I need to ask our IT dept. for our portal  setup or may be
it is just a small fix on our end.

Answer #9    Answered By: Cristopher Gould     Answered On: Jan 08

You have to activate the publishing  Infrastructure under the Site
Collection Features on the Top level site  of the site collection before
you can activate the publishing Site Feature. That (the Publishing
Infrastructure Feature) is the one its complaining that hasn't been
turned on.

Didn't find what you were looking for? Find more on Publishing Infrastructure feature error Or get search suggestion and latest updates.