Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Publishing Info Path form

  Asked By: Fredrick    Date: Jan 01    Category: MOSS    Views: 1586

When I am Publishing InfoPath form, i publishing wizard step three,
There is a option "what do you want to create or modify?"
Which have three options
1) Document Library
2) Site Content type
3) Administrator- approval form template (Advance)
I am getting the following message "Administrator must approve this
form template before it can be filled out by using a browser"
And getting the "Document Library" and "Site Content type" option
disabled and only "Administrator- approval form template (Advance)"
option enable
Can anyone help me, I want all the option to enabled, what setting i
should do in MOSS 2007 or Info Path so that i can create a document
library from this form template.

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Jonathan Scott     Answered On: Jan 01

It sounds like you have something in the form  that requires it to have
Full Trust. Fully trusted forms in WSS v3 can't be directly published to
a form library. Do you have any managed code behind the form? Are you
making any web service calls? With a fully trusted form, the process to
publish to a WSS form library  is as follows:

1.Publish from InfoPath, choosing the Administrator-approved option.
You will have to choose a location on the file system to publish the
administrator-approved template  to.
2. Upload published form to form template library in Central
Administration
3. Activate the form to the site  where you want to host it
4. Create a form library and add the newly activated Content Type to
the form library.

This is a quick overview, I can provide more details on the steps if you
need. If you remove whatever is causing the form to require full trust
you should get the option  back to publish directly to a document
library.

 
Didn't find what you were looking for? Find more on Publishing Info Path form Or get search suggestion and latest updates.




Tagged: