Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Problems with user

  Asked By: Grace    Date: Oct 02    Category: Sharepoint    Views: 614

I was asked to trouble an issue with a WSS v2 site. Initially, the account had the person's AD account listed, but had someone else's display name. I went ahead and changed that person's information to be accurate, but when I attempt to add the second person's AD account to the site, I get an error saying that the user already exists. I can find no mention of this anywhere. I have run several refreshes of the People index as well as searching the USERINFO table in the content database. I have also run an enumusers function with STSADMIN but I can find no evidence of this user existing. Any ideas? At this point I'm tempted to do a STSADM backup, delete the site, and then a STSADM restore to see if that fixes the problem.

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Kristina Cox     Answered On: Oct 02

If you've only changed  the properties of the user  in AD, the SID of the user is still the same. So, you started with a user having "1234" as their SID - all you did was change an attribute of this user (name) but this does not add  a new SID. So, when you try to add that user, it compares SID's of existing  user and voila, user with SID 1234 already exists". My suggestion is to delete  the user entirely in AD (if possible) and add him/her again. There may be other ramifications of doing this so proceed accordingly.

 
Answer #2    Answered By: Delbert Frederick     Answered On: Oct 02

You might want to look at this link about dealing with renaming
users: blogs.msdn.com/.../534752.aspx

 
Didn't find what you were looking for? Find more on Problems with user Or get search suggestion and latest updates.




Tagged: