Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Problem with Variations and ASP.NET webparts

  Asked By: Deborah    Date: Jul 29    Category: Sharepoint    Views: 1922

I have a problem with Variations and ASP.NET webparts. Here is what I do:

Create a new webapplication + site collection (standard Publishing Site). Server is setup in farm mode.
Setup variations. Root is /, Source language en-US, two variations Danish (da-DK) and English (en-US)
Create variations. Everything is fine
Create page (std. Blank Web Part Page). Enter some text. Approve, Publish. Page is copied to Danish and English just fine
Create another page(std. Blank Web Part Page). Enter some text. Add a webpart inheriting from Sharepoint Webparts. Approve, Publish. Page is copied to Danish and English just fine
Create yet another page (std. Blank Web Part Page). Enter some text. Add a webpart inheriting from ASP.NET Webparts. Approve, Publish. Page is only copied to first variation and now messages in the variation log (an entry is made, but nothing in either success or failure).
The webparts are Hello World type of webparts:

Code Block


namespace test

{

public class AspNetWebPart : System.Web.UI.WebControls.WebParts.WebPart

{

public override void Render(System.Web.UI.HtmlTextWriter writer)

{

writer.Write("Hello, I'm a ASP.NET 2.0 WebPart");

}

}



public class SharePointWebPart : Microsoft.SharePoint.WebPartPages.WebPart

{

public override void Render(System.Web.UI.HtmlTextWriter writer)

{

writer.Write("Hello, I'm a Sharepoint WebPart");

}

}

}

}

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Ahmad Johns     Answered On: Jul 29

Known bug, a hotfix is in the works. Thanks for the very detailed repro steps here, great detective work.

 
Didn't find what you were looking for? Find more on Problem with Variations and ASP.NET webparts Or get search suggestion and latest updates.




Tagged: