Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Problem with a userid

  Asked By: Sanchay    Date: Jul 03    Category: Sharepoint    Views: 786

We have some people that have an alias associated with their Active
Directory account. When such a person is added to our WSS site, the
alias and the name show up. The person associated with such an id left
the company. We have a replacement for that person. The old alias is
now associated with the new person in AD. The old person has been
deleted from SharePoint, or so we think. When we try to add the new
person in as a valid user, we are blocked from doing this because
SharePoint still thinks the old person exists, even though all the
sites have been cleaned of the old person. I suspect that in some sql
server table, SharePoint is not letting go of the old id. Does anyone
know how to fix this?



5 Answers Found

Answer #1    Answered By: Willard Valenzuela     Answered On: Jul 03

This is a pretty common problem  with Sharepoint.
Google "SPUserUtil." It was written by Keith Ritchie and it will
prune out the old entries so that you can add  the new ones.

You can also remove users at the Site Collection level under Site
Settings, Site Administration, Manage Site Users. I'm not sure if
you'd be able to fix  this particular issue from there or not though

Answer #2    Answered By: Damon Garner     Answered On: Jul 03

If the old user  needs to be removed from the site  collection, then delete him

Forgive me, I'm going from memory here as I don't have immediate access to a SPS server:
- make sure you're at the top web in the site collection
- site settings
- Go To Site Administration
- Go To Top-Level Site Administration (last link on bottom if it exists, otherwise proceed to next step)
- View Site Collection User Information
- Find the user you want to remove, check their box and click Remove Selected Users.

Answer #3    Answered By: Emmett Hyde     Answered On: Jul 03

Have you checked the user  information table? http://site.com/_layouts/1033/userinfo.aspx

Answer #4    Answered By: Michelle White     Answered On: Jul 03

Have you tried using /_layouts/1033/siteusrs.aspx

Answer #5    Answered By: Sheena Ray     Answered On: Jul 03

This is an issue I have seen once before on a test rig I was working with. The issue was caused by the Users table  in SQL still having the users in there even they had been deleted. There is a flag in that table called bDeleted, which gets set to 1 when a user  is deleted. However for some weird reason these users were still being picked up. The easiest way I found to sort this was to run a regular SQL Delete statement against this table. I tried this as a one off but the users kept appearing.

I would say at this point that I would not advocate anyone making any changes to the SQL Tables that are used by SharePoint. There are slight implications with MS Support if you do.

Anyway just thought I’d pass the info on.

Didn't find what you were looking for? Find more on Problem with a userid Or get search suggestion and latest updates.