Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

problem in search....

  Asked By: Parvesh    Date: Jan 05    Category: Sharepoint    Views: 796

below is my requirement..........

When I was trying to search for a word it was taking the complete word as one sentence.

For example if Iam trying for a word like (Market Structure), a word with spaces; it is searching for the complete word (market structure) with space. But I want the results of search like

1. all results on Market
2. all results on Structure
3. all results on Marketstructure(with out spaces)
4. all results on Market Structure

But I was getting only the results of fourth point(all results on Market Structure).

Share: 

 

3 Answers Found

 
Answer #1    Answered By: Katelynn Donovan     Answered On: Jan 05

The search  that you were trying is a wild card search which is not present in MOSS by default. For your search to work best way is try and see some 3rd party products that does the wild search on top of MOSS. In search we have another feature which by default off. Its the search stemming. What it does is like if you search "enjoy" then it will also search for "enjoying". I hope its clear for you.

 
Answer #2    Answered By: Geraldine Slater     Answered On: Jan 05

I am New to Moss 2007, in my office we installed Office SharePoint Server 2007 Std, Data Base Server is SQL 2005 Std, Win 2003 sp2 STD , Dot Net Frame Work 3.0(2.0 is also availabe).

Initially everything went on Safe and Smooth, but while rollout to my branch Office(Bag, Mum,ete..) due to proxy settings we are not able to access our SharePoint Server through Lan(Dedicated VPN(pipe line) Line for to connect all branch Office through LAN) we change the Authentication in Inetmgr as Basic Authentication from Digest domain Auth and Windows Authendication.

Now we are able to connect from branch Office, but Suddenly search  is not working, the above mentioned error is coming. Suddenly SharePoint loging membership account is also randomly changed, for Example, If i login As Suresh, fullcontrol account in welcome message some other account is showing for example  Welcome Kumar. If i open any Department Site and it's Sub Site the Login Name is Randomly Changed-showing some other user's account name,

So i took data base back up and completely uninstalled my MOSS and freshly configured and again reconnected my Database to present Configuration, Now every thing working fine. I am able to crawl and and Schedule, successfully scrawling no error-even the user profile import , No change in Old Setup. now No user Login Problem.

BUT ONLY problem  IS SERARCH, SEARCH IS NOT WORKING. IF TYPE SOME THING IN MY SERCH BOX i.e Meeting I AM GETING THE WEB PAGE CANNOT BE FOUND HTTP 404.

I searched some Fourm but no gain, Friends i am completely helpless, so Finally I am posting My Issue Here, If any body faced this problem, Please share and Give me your Suggestion as soon as Possible.

 
Answer #3    Answered By: Gail Richmond     Answered On: Jan 05

1. Go to Site settings of your site coll and click on search  settings.
2. Copy search site and check whether the search site is present or not. If yes directly from web browser go to search site.
3. Once u come to search site type same keyword and search. If you are not seeing search results  then do following
a. edit search content source in search settings under SSP and check whether all ur web apps r there or not.
b. If web app not present then please add the web app.
c. Reset all crawled search content and do a full crawl.
4. Even after that if u r still facing same issue can you please check event logs and send if anything is reported.

 
Didn't find what you were looking for? Find more on problem in search.... Or get search suggestion and latest updates.




Tagged: