Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Possible bug in sharepoint 3.0 installer...

  Asked By: Johanna    Date: Dec 17    Category: Sharepoint    Views: 1183

I ran across this the other day and thought I would document it and share it
with you all in case you are experiencing the same:


Some of you may have encountered a problem where you are trying to perform a
gradual upgrade to Sharepoint 3.0 or MOSS but the gradual upgrade option is
grayed out. After much searching on Microsoft’s site and the web, the only
information I could find regarding a root cause was that MSDE was previously
installed or currently installed on the system and I guess gradual upgrade is
not supported with MSDE (standalone install). I was not using MSDE and this
problem was very aggrevating. I had created a fresh sharepoint farm with
dedicated sql2005 database and yet I still encountered the same issue where the
“Yes, perform a Gradual upgrade” was grayed out. After a few days of
troubleshooting, I decided to run filemon against the installer to see what
registry keys and files it was accessing so I could figure out how it was
deciding to gray out that box. In only a few seconds, around 100,000 operations
were performed on files and reg keys. After some digging and filtering, I found
something kinda odd.. It was querying the value of the database dsn key for the
SharePoint database configuration. [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared
Tools\Web Server Extensions\Secure\ConfigDb] In this case, I had a database
server named “sharepointsql” and the instance was named “sharepoint”. So the
value of my dsn key was:
“Provider=SQLOLEDB;Server=sharepointsql\SHAREPOINT;Database=SharepointConfig;Use\
r Id=;Password=”It then occurred to me that every time where the gradual upgrade
option was grayed out, the database instance was named SHAREPOINT. I also
remembered that this is the default name for a MSDE installation of SharePoint.
I renamed the instance in the dsn to
say:“Provider=SQLOLEDB;Server=sharepointsql\SOMEKINDABUG;Database=SharepointConf\
ig;User Id=;Password=”When I ran the installation, the “Yes, perform gradual
upgrade” option was not grayed out… I was still a bit worried that the dsn value
was being stored somewhere in the initialization of the installer. As soon as I
check thed “Perform gradual upgrade” option, I changed the registry key back to
the original value. The installation completed successfully! I then did a file
system and registry search on the keyword “SOMEKINDABUG” and no results were
returned. Everything else from this point on worked perfectly. So it seems that
some crazy developer at Microsoft coded the installer to check and see if the
database instance was named “SHAREPOINT” and made the assumption that the
database muse be MSDE. (SHAREPOINT1, SHAREPOINT2, SHAREPOINT(N) also fail). I
have not filed the bug with Microsoft yet but will probably do so this week.
Anyway, I thought documenting this might save some time for some of you out
there who were foolish like me and named your database instance SHAREPOINT.

Share: 

 

No Answers Found. Be the First, To Post Answer.

 
Didn't find what you were looking for? Find more on Possible bug in sharepoint 3.0 installer... Or get search suggestion and latest updates.




Tagged: