Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Portal Level Document Library

  Asked By: Edmond    Date: Oct 20    Category: Sharepoint    Views: 2859

How can I allow all domain users the ability to upload documents to a portal level document library but not allow them access to upload anything else. Right now the are all readers at the portal level. When I tried to modify the permissions and give them the ability to add items it gives them the ability to to add items to list and other areas that I do not want them to have access to. I did not see where I could restrict access to the portal level doc library like you can at the team site side.

Does anyone know of a workaround?



7 Answers Found

Answer #1    Answered By: Kalyan Pujari     Answered On: Oct 20

The security model is such that SPS pages are a "per page" level  security; there is no way OOTB that you can change this.

Answer #2    Answered By: Christop Mcfadden     Answered On: Oct 20

I know this is a work-around, perhaps you could make a single page sub-site with the “portal library” add-item privileges.

Answer #3    Answered By: Gopal Jamakhandi     Answered On: Oct 20

Appending this to the URL of your Portal will give  you all the OOTB SPS permissions: _layouts/1033/spaddrole.aspx but it appears as though you want to give list level  security, only available in WSS.

Ross's solution is the quickest work around. If your users  are uploading documents, the use of a WSS site  is perhaps more appropriate anyway.

Answer #4    Answered By: Chantal Rosa     Answered On: Oct 20

The UI in the portal  does not allow you to set the permissions  at the list/library level, but there is a back-door method.

See this blog weblogs.asp.net/.../317136.aspx by Bil Simser on how to do it.

Answer #5    Answered By: Kyla Eckert     Answered On: Oct 20

I may be mistaken, but I believe the latest service pack removed that back door.

If you try this method and get an authentication prompt when you do it, then this option is no longer available to you and has been removed by the service pack.

Even if you do get it working, it's a back-door and one that Microsoft will likely take away from you with a future service pack. If they take it away from you and your permissions  are still set, you will not be able to get into the UI to change them and then you'll really be stuck.

A WSS site  is the best bet for this.

Answer #6    Answered By: Alisha Holmes     Answered On: Oct 20

I can’t remember if I’ve ever tried it out or not, but it’s good to know that the back door has been removed.

Answer #7    Answered By: Laura Walker     Answered On: Oct 20

Create a single area just for this purpose, place the document  library in that area and quarantine this activity to a single area where nothing else is happening.

Didn't find what you were looking for? Find more on Portal Level Document Library Or get search suggestion and latest updates.