Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

cannot place webpart on page

  Asked By: Sarojini    Date: Aug 27    Category: MOSS    Views: 680

Running MOSS 2007 SP2



We just recently moved our SharePoint databases from one database server
to another (from 32bit to 64bit). Unfortunately the move did not go as
smoothly as we hoped. One thing that is not working is one of our
custom web parts. When the move was complete, we noticed that this web
part no longer worked. I deleted it from the page and was going to
remove the solution and re-add it, but I have some strange results.
Frist, the web part is listed in the add a web part list, but not in the
solutions page in CA. This being said, I cannot just read the web part.
Also, when I try to add the solution using stsadm, I get this error:
"Object reference not set to an instance of an object.

e:\webparts\careernet\careernet_icon.wsp: The Web Part deployment
failed."



How can I get it removed from SharePoint so that I can get it re-added?
All suggestions greatly appreciated.

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Gobinda Navalagi     Answered On: Aug 27

Have you tried to deactivate/retract/uninstall the feature before re-adding
it?

 
Answer #2    Answered By: Rose Silva     Answered On: Aug 27

Yes I have. Still giving me trouble.............

 
Answer #3    Answered By: Maegan Ellison     Answered On: Aug 27

Its still showing up in the add a web part dialog because the .webpart file
is still in the gallery. That would have come with the content database.
Unfortunately, the farm solution would have been stored in the config
database and I suspect that's where the problem lies. I would manually
delete it from the web part gallery and then try re-adding the solution

 
Answer #4    Answered By: Yahaira Shannon     Answered On: Aug 27

this is the case. There was a problem with the move of the config
database, thus it had to be recreated. I have found it in the gallery
and removed it and then ran the stsadm -o addsolution command, then
tried to deploy it and it gets stuck deploying. I then ran the stsadm -o
execAdmSvcJobs command. It seems to be stuck in the Deploying stage. It
is only being deployed to one site collection. I have even tried an
IISReset.

 
Didn't find what you were looking for? Find more on cannot place webpart on page Or get search suggestion and latest updates.




Tagged: