Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Perplexing ASP.NET error

  Asked By: Antoinette    Date: Apr 30    Category: Sharepoint    Views: 1020

1) I received the error:

"The Windows SharePoint Services virtual server has not been
configured for use with ASP.NET 2.0.xxxxx.0. For more information,
please refer to Knowledge Base article 894903 at
http://go.microsoft.com/fwlink/?linkid=42660"

2) I used the cmd they recommend: stsadm.exe -o upgrade -
forceupgrade -url http://URLOftheVirtualServer. The command runs
with no errors.

3) All seems well, but the error will occur re-occur by the next
morning. An IISRESET fixes the problem every time. I have
scheduled this task to run every morning as temporary fix.

--I have review the following logs: server, IIS, SQL, SPS. There is
NOTHING conclusive.
--I have gone through each website and verified they are not running
on .NET 2.0
--As a test, I switched the websites to run on .NET 2.0, ran the
upgrade command, reset IIS, and everything broke. I verified the
web.config file was changed. I switched the websites back to .NET
1.1, resetIIS, and ran the upgrade command. All worked fine again.
Two days later, same problem.

4) From reviewing the Default Website IIS logs, the problem only
occurs on my prod box, and between the hours of 2-6am. I have
looked at all jobs, services running, and still no joy.

5) My thoughts on possible courses of action:
--uninstall .NET 2.0 to void chance of SPS "thinking" it has a
choice between .NET 1.1/2.0
--uninstall all .NET, and re-install
--As a test, I uninstalled .NET 2.0 from my Beta server (down to
1.1) and it seems to be fine.

Server: Win2K3 R2 SP1. SPS2003 SP2, WSS 2.0, .NET 1.1/2.0, SQL 2000
SP4. All current updates.

Any ideas?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Tiana Whitaker     Answered On: Apr 30

This issue comes up fairly regularly in some form. Even though you
can configure a web site in IIS manager to run under a particular
version of .NET, the runtime still sometimes goes looking around the
machine and tries to load a component that requires a different
version. There is an entry you can make in web.config that forces
the runtime to only load components from a specified version.

<configuration>
<startup>
<requiredRuntime version="v1.1.4322"/>
</startup>
</configuration>

 
Answer #2    Answered By: Alice Chandler     Answered On: Apr 30

knoxcameron, is this an argument for installing features to a site
instead of to the GAC?

 
Answer #3    Answered By: Lynette Sawyer     Answered On: Apr 30

I guess it could be, though I don't think you could completely avoid
the issue. The runtime follows chains of dependencies, and sometimes
seems to get a bit lost!

 
Answer #4    Answered By: Alisha Itagi     Answered On: Apr 30

Well, that would explain why the site would still be trying to
revert back to 2.0! Thanks for the suggestion. After all the
googling, I couldn't find anything to force the machine to use 1.1
without removing 2.0. I ended up uninstalling 2.0 and all seems
fine. However, if I need to run 2.0 again, I'll use your tag. Most
likely, we'll be upgrading to 2007, so this won't be an issue
again.

 
Didn't find what you were looking for? Find more on Perplexing ASP.NET error Or get search suggestion and latest updates.




Tagged: