Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Permissions?

  Asked By: Demarco    Date: May 22    Category: Sharepoint    Views: 636

I have a user who has been accessing a site with no problems. Now when she goes there she is prompted for a user/pass it rejects her login three times and then lets her into the site. However the site is not displayed correctly, it looks as if it is missing it's style sheets. Changing the users permission level has no effect. However if she uses another account (an admin account) on the same computer it works without a problem.

Share: 

 

15 Answers Found

 
Answer #1    Answered By: Damon Garner     Answered On: May 22

Sounds like it might be a client-side issue. Have you tried
clearing the client browser cache? Is the user  able to log in,
using her regular account, from another client?

 
Answer #2    Answered By: Dameon Dejesus     Answered On: May 22

Judging by your "remove a template" question is sounds like something on the
server's file system has been changed and the non-admin user  doesn't have access
to it. Maybe a .CSS file or something. If you know what files you've changed,
make sure they have the correct permissions.

 
Answer #3    Answered By: Tejaswani Barve     Answered On: May 22

I have made changes to css files but only to classes. How would I check permissions  to a CSS file?

Another thing... they upgraded IE as well. Everything still works  fine on my end but could this have an effect  on lessor permissions or CSS files?

 
Answer #4    Answered By: Harshita Padwal     Answered On: May 22

Yep, the cache was cleared but it didn't help. I don't know if the user  tried her credentials on another client but when she used someone else's credentials on her computer  it worked fine.

 
Answer #5    Answered By: Jennifer Jones     Answered On: May 22

Do you have another install of SharePoint somewhere? I'd compare the
permissions on the files you edited on a different install. Like in
themes questions, what did you use to make the changes?

 
Answer #6    Answered By: Annie Norris     Answered On: May 22

I bet what happened is that the permissions  on the style  sheet files got corrupted.

Log on to the front-end web server, browse to the layouts\1033\ folder, right-click on the styles folder and select properties. Click on the security tab, and click the Advanced button. Check the box to “Replace permission  entries on all child objects…”. Click OK and OK.

See if that resolves the problem.

This typically happens if you copy the .css files (or any files) from one computer  onto the front-end web server. The files end up not picking up the permissions that it should.

 
Answer #7    Answered By: Chadd Hahn     Answered On: May 22

I had a similar issues yesterday. Did you change a system style  sheet or create a new one?

If you changed a system style sheet through Sharepoint Designer you need to select it in the folder tree, and publish it from there. Once the style sheet is checked in and published, your "normal" users  can see your changes.

 
Answer #8    Answered By: Cheryl Kelley     Answered On: May 22

My guess is that there was a web part added to the page that this
person does not have permission  to see. So, when they try to access
the page, they are getting prompted  for their credentials just for
that specific piece of the page, but the rest of the page is ok (and
is viewable by this person). You'll have to figure out what part of
the page this person does not have access to, and then fix the
permissions for that specific piece.

 
Answer #9    Answered By: Kalyan Pujari     Answered On: May 22

I had similar problem  a while back. What happened in my case was one of our web
developers moved a file to the webserver and its permissions  were explicit and
not inherited. No uers had access to the file xcept the admin  and the web
developer.

I had to sniff out the file on the frnt-end serve under the virtual server
folders in the file system. Once i fixed the permissions everything worked
again.

What i would do in your case is go into iis on the webserver, find the files for
the page throwing the error and verify each nes permissions (properties security
tab) and make sure they are all consistent..

 
Answer #10    Answered By: Jagdish Joshi     Answered On: May 22

We are talking about 2000 users  not having an issue and maybe 10 people are experiencing this issue. ALl 2000 users belong to the same AD group. And once the user's profile ios recreated the issue is fixed

 
Answer #11    Answered By: Shara Johnson     Answered On: May 22

did all these 10 users  upgrade their browsers to IE7.0 (as I believe this was eluded to later in the thread after the original post)?

Other things to check...

- WindowsNT Authentication is flaky if not non-operational through certain types of proxies...Bypass your proxy server, see if you still get prompted.
- Add your domain suffix to the "Trusted Sites" in IE. And make sure that in the security settings for your Trusted Sites zone, it is set to "Automatically pass logon name and password"

Try that...

 
Answer #12    Answered By: Christop Mcfadden     Answered On: May 22

I really couldn't add anything of more value......

 
Answer #13    Answered By: Cassidy Sharpe     Answered On: May 22

have you tried using her account  on a different pc. I have seen the local profile do some strange things.

 
Answer #14    Answered By: Damon Garner     Answered On: May 22

have you tried removing stored passwords from start>control panel>user accounts>advanced

 
Answer #15    Answered By: Hans Weiss     Answered On: May 22

I work for a large organization We have being seeing the same problem  mentioned.
We check the stored passwords in Control Panel, we clear out IE cache!
The only thing that works  is deleting and recreating the user  Profile
Now the user usually only has a problem on one machine
If anybody figures out a better way please let me know..

 
Didn't find what you were looking for? Find more on Permissions? Or get search suggestion and latest updates.




Tagged: