Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Page Editing Toolbar Doesn't Appear For Page Owners

  Asked By: Leila    Date: Feb 13    Category: Sharepoint    Views: 4820

I've a Publishing Site, and within this is the default Pages
Document Library. I have multiple pages in here. What I'm trying
to do is have different people own different pages (User A owns
Page1; User B owns Page2; etc). The stickler here is that while I
want them to own a page, I do not want them to have the ability to
add new ones to the Pages library. Simple, yes?

Thinking that it was just an Item Level Permission issue, I gave the
individuals Full Control of their respective pages, but still having
Read access to the Pages library. Doing this prevents the Page
Editing Toolbar from showing up on their respective pages.

If I give the user Design or Contribute rights to the Pages library,
then the P.E.T. appears, but this also give the user permission to
create new pages as well, something I do not want.

Does anyone have any ideas on how to remedy this? The bigger issue
is that, while a user has Full Control over a page, but only Read to
the Pages library, they can edit the page but without the P.E.T.
they cannot save/check-in their changes.



3 Answers Found

Answer #1    Answered By: Talia Johns     Answered On: Feb 13

Have you considered creating sub-sites under your publishing  site?

You can have each person be the owner of a sub-site and it's pages.

Depending on what you want to do, there are ways to display links on
the top level site  to the pages  in the sub-sites.

Answer #2    Answered By: Tera Callahan     Answered On: Feb 13

Giving those individuals their own subsites isn't really an option
here. They're having issues committing to handling their own pages,
let alone all of the stuff that comes with sites. I should have
stipulated that in the opening post. Creating subsites is not an

Answer #3    Answered By: Mark Davis     Answered On: Feb 13

After some playing in my DEV environment I figured I'd post my
resolution, and then folks can respond if there would be a different
way to do this.

The issue  was that the individual didn't have the correct level  of
access in the pages  document library  and this was preventing the
Page Editing Toolbar from appearing. To give  the individual the
relevant permissions I created a new permission  level named Page
Owner with the following levels:
- List Permissions: Edit Items, Delete Items, View Items, Open
Items, View Versions, Delete Versions, View Application Pages
site  Permissions: View Pages, Open

I then created a group (page Owners) with access  to the Pages
document library, containing those users that would own pages, and
gave this group the page  Owner permission level.

After that, I broke inheritance for each of the pages in the Pages
library, removed the Page Owners group (as they were there cause of
inheritance), and added the spcific user  that I wanted to "own" the

The above allows the user to have a P.E.T on their page, but not
have any other level of access to modify the Pages doc lib.

Didn't find what you were looking for? Find more on Page Editing Toolbar Doesn't Appear For Page Owners Or get search suggestion and latest updates.