Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Office Sharepoint Server Search Configuration problem - page render

  Asked By: Antoinette    Date: Dec 23    Category: Sharepoint    Views: 1970

I have 3 servers in my test farm and I finally decided to get some patches
applied so i put on a bunch of os update and went from sp1 to feb updates.
Everything looks good except I get an error when I try to configure the "Office
SharePoint Server Search" on the server that was congiured as the indexer. I
stopped the service and moved to another server but I would like to move it back
to the original server. I am getting an page render issues vs the standard
non-useful error message.

I have gone back on all the servers and ran psconfig again and booted all boxes
with not fix. See the error page below.

An unhandled exception occurred in the user interface.Exception Information:
Client found response content type of 'text/html; charset=utf-8', but expected
The request failed with the error message:
<title>Runtime Error</title>
body {font-family:"Verdana";font-weight:normal;font-size:
p {font-family:"Verdana";font-weight:normal;color:black;margin-top:
b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red
H2 {
font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
pre {font-family:"Lucida Console";font-size: .9em}
.marker {font-weight: bold; color: black;text-decoration: none;}
.version {color: gray;}
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy;
cursor:hand; }

<body bgcolor="white">

<span><H1>Server Error in '/' Application.<hr width=100% size=1

<h2> Runtime Error </h2></span>

<font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

Description: An application error occurred on the server. The
current custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It could,
however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute set
to "Off".

<table width=100% bgcolor="#ffffcc">

<!-- Web.Config Configuration File -->

<customErrors mode="Off"/>


Notes: The current error page you are seeing can be replaced by a
custom error page by modifying the "defaultRedirect" attribute of the
application's <customErrors> configuration tag to point to a custom error page

<table width=100% bgcolor="#ffffcc">

<!-- Web.Config Configuration File -->

<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>





2 Answers Found

Answer #1    Answered By: Sandra Alexander     Answered On: Dec 23

Corresponding error  in event viewer
EventType ulsexception12, P1 w3wp.exe, P2 6.0.3790.3959, P3 45d6968e, P4
microsoft.office.server.search, P5 12.0.6219.0, P6 49a49da2, P7 2973, P8 183, P9
invalidoperationexception, P10 837w.

Answer #2    Answered By: Nalin Rao     Answered On: Dec 23

I got lucky and figured it out from another post. Someone mentioned trying to
get the to web services (http://server:56737/searchadmin.asmx) and received an
error one the local  box about an invalid object. I then rememeber some
permission errors I received during infrastructure updates  on another farm  and
check the permission on the iis wamreg admin service  in dcomcnfg and made sure
wss_admin_wpg had proper permission and it fixed the problem.