Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Office Search Issues

  Asked By: Harshit    Date: Feb 23    Category: Sharepoint    Views: 684

This has been an ongoing prob now, ill try to make sure to throw in
as much info as needed for a good description.

We have a 5 server SP farm. 2 Front Ends, 1 Indexer, and a SQL cluster
(2 servers, primary and failover)

I have a script that runs a full farm backup nightly. It will send me an
email on success or fail of that run. I noticed that I got no email at
all the other morning, so I went in and initiated the script manually so
that I could watch the backup in the command window. Sure enough, it
hung up on 50% at shared services index. Now this isn't my first rodeo,
and this has happened in the past. Usually when our secretive Info
Assurance team applies "mandatory" patches without telling the rest of

So here we are. I went onto the indexer and did an stsadm -o osearch
-action stop and then start. Last time this worked like a champ.
Performed a full crawl and bam, everything was back....

This time...

Stop and start through stsadm worked fine. I noticed however, that
central admin never registered the service stop and restart...

I went into the SSP and reset the index settings. Clicking on search
settings gives you this:

The search service is currently offline. Visit the Services on Server
page in SharePoint Central Administration to verify whether the service
is enabled. This might also be because an indexer move is in progress.

Gave it time (about 6 hours later..) and search is still not registering
a thing.

I have scheduled a reboot of the farm tonight with our SA team (they
have to do some windows patches anyway, least they tell me) but I am not
satisfied at this point that this will have a bearing on my search..

Also, when attempting a restart from cent admin, it just sits on

I have also verified that the duplicate entry box has be checked on the
appropriate tables in SQL.



2 Answers Found

Answer #1    Answered By: Perla Vang     Answered On: Feb 23

This issue has been resolved. Looks like it was a combination of many

The sharepoint  timer service  was stopped (is there a reason that the
timer services  are set to manual?) I started them.

We are having some DNS issues  with users accessing our new url. The
network guys are still working that problem. Evidentally when I changed
the AAM to the new public url, and it changed that web app as well, the
index server  was unable to navigate there. I am suspecting the same
reason (the DNS issue). Once I added the old path into the url search
range, the index  started working once again.

Answer #2    Answered By: Sandra Alexander     Answered On: Feb 23

Have some what of a similar problem.
The Index server  was stopping at 50 percent when backing up.
I am running two WFE and a separtate server for INdexing and
searching. Turns out the timer was set to manual on the server. Whihc
is why it was not completeing backup.
Have started it now and hopefully it should complete.

Didn't find what you were looking for? Find more on Office Search Issues Or get search suggestion and latest updates.