Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Office Authentication

  Asked By: Gaurang    Date: Jan 11    Category: MOSS    Views: 718

When users open an office document from sharepoint they have to
authenticate, even though I.E. has already automattically authenticated
them using their windows credentials.

Is there a setting to eliminate this?

Share: 

 

12 Answers Found

 
Answer #1    Answered By: Collin Griffith     Answered On: Jan 11

Is it Vista and Office 2007? If so, you may need to do some extra config
on the client.

 
Answer #2    Answered By: Scott Nelson     Answered On: Jan 11
 
Answer #3    Answered By: Blake Marshall     Answered On: Jan 11

Thank You. I posted the other message prematurely.

 
Answer #4    Answered By: Dwayne Jensen     Answered On: Jan 11

Does "Known bug" mean that Microsoft is working on it and will release
a patch soon?

 
Answer #5    Answered By: Jose Baker     Answered On: Jan 11

"Known" only means they know about it - it's on a bug-by-bug basis
whether and when they plan to fix it.

 
Answer #6    Answered By: Cornelius Guerrero     Answered On: Jan 11

Wishful thinking. We have logged the bug with MS and after being bounced back
and forth between WSS, Office and Vista support, they close our bug report
without acknowledging a "bug". I believe it will be fixed, this is definitely an
issue with Vista because it wasn't an issue with XP.

 
Answer #7    Answered By: Roderick Wolfe     Answered On: Jan 11

Yes it is.

Would you happen to have a link that can teach me to do this?

 
Answer #8    Answered By: Johnny Cruz     Answered On: Jan 11

Create a bogus proxy entry in IE, then exclude * from using the bogus entry.
That will force office  07 to use a different auth module.

 
Answer #9    Answered By: Norman Santos     Answered On: Jan 11

It worked. That was it.

What an extraordinarily interesting fix.

I suppose that is a bug in Vista and can’t be fixed with a SharePoint patch
huh?

 
Answer #10    Answered By: Walter Stone     Answered On: Jan 11

We just tried this and it worked. Then we noticed that all sites
began showing up in the browser as "Local Intranet". Might be
because of the way our policies are set up or not; don't know.

When I removed the bogus proxy, the websites browsed began showing up
in their correct security zones again.

 
Answer #11    Answered By: Jamar Yates     Answered On: Jan 11

I'm seeing the same thing. When I set up the fake proxy, all sites
show up as being in the local intranet zone. That's a little less
than ideal.

The Microsoft KB article on this
(http://support.microsoft.com/kb/932118) suggests adding the
Sharepoint site to the trusted zone but all that seemed to do for me
was force the Sharepoint site to load in a separate browser. It still
prompted me to log in when I tried to open  the document.

From the KB article, it doesn't sound like this is acknowledged as a
bug but rather a consequence of a more secure environment.

Are there any other workarounds or even hope that Microsoft will fix this?

 
Answer #12    Answered By: Aaron Lopez     Answered On: Jan 11

I had to figure this out tonight, and it was very simple.

Yyou can turn off 'Include all Sites that bypass the Proxy Server' in
the Local Intranet, Sites, Local Intranet Zone settings.

 
Didn't find what you were looking for? Find more on Office Authentication Or get search suggestion and latest updates.




Tagged: