Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Not able to deploy web part using stsadm.exe

  Asked By: Stephanie    Date: Feb 10    Category: Sharepoint    Views: 6709

Using a stsadm.exe tool when I try to deploy web part, it throws an
error message

"The server instance specified was not found. Please specify the
server's address and port."

But able to run stsadm.exe with "enumwppacks" option which displays
all the web parts deployed.

Any idea on this problem and how to solve it?

Share: 

 

7 Answers Found

 
Answer #1    Answered By: Riley Scott     Answered On: Feb 10

Double-check your syntax - if you are making a mistake with that you will
sometimes get that error message...

 
Answer #2    Answered By: Adya Khavatekar     Answered On: Feb 10

Checked the syntax, its fine. I feel its something to do with IIS.

Here is the syntax what I enter :

stsadm.exe -o addwppack -filename xyz.cab -globalinstall -force

 
Answer #3    Answered By: Trupti Patil     Answered On: Feb 10

Nope, it's your syntax - you are missing the -url flag which is needed for
addwppack but not for enumwppacks.

 
Answer #4    Answered By: Marlena Noble     Answered On: Feb 10

-url flag required only when the web  part is being deployed  to a specific
virtual server.

Without -url flag will deploy  the web part  on all the available virtual servers
on the IIS.

In my case, we have 2 virtual servers, so tried without -url flag.

But anyways I tried with -url flag, still no luck ...

 
Answer #5    Answered By: Juan Davis     Answered On: Feb 10

you are right -url is an optional parameter in addwppack. We don't have
to specify the url.

 
Answer #6    Answered By: Jason Anderson     Answered On: Feb 10

Does this SPS machine have multiple IIS virtual servers on it? Are you
using Host Headers or IP Address to differentiate the virtual servers?

 
Answer #7    Answered By: Uttam Vanjare     Answered On: Feb 10

Finally was able to solve  the problem...

Solution : Run stsadm.exe -upgrade

 
Didn't find what you were looking for? Find more on Not able to deploy web part using stsadm.exe Or get search suggestion and latest updates.




Tagged: