Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Newly added groups/users cannot access workspace, get access den

  Asked By: Jackson    Date: Oct 04    Category: Sharepoint    Views: 2067

I have 3 workspaces on our server. The problem is that every time I
try to give access permissions such as the reader or author role to a new
user or a group, they cannot access the workspace. They keep on getting an
access denied error, as if they did not have rights. If I restart IIS
services (W3SVC, Exchange Info Store, and SMTP)and the SharePoint service or
reboot the server, they are able to access it just fine. I should not have
to do this because users/groups should be given rights instantaneously.
This happens to both local users and groups as well as domain users and
groups. I am running the released version of SharePoint, not an Eval or
Trial version. Any ideas or fixes? I have also flushed the application
level cache but this has not helped. In addition, I have just tried to
restart the Exchange Info Store and SharePoint but this does not work
either. I have to either reboot or restart the IIS services, Exchange Info
Store, and SharePoint.



8 Answers Found

Answer #1    Answered By: Nalin Rao     Answered On: Oct 04

If you add global groups  to SPS and then add people to the groups, this is no
longer an issue.

Answer #2    Answered By: Thomas Davis     Answered On: Oct 04

I wouldn't assume that MS knows it is widespread. Did you all let MS know that
you were having the problem? I would hate for all of us to be waiting on a patch
that none of us has reported needs to be made.

Answer #3    Answered By: Dominic Davis     Answered On: Oct 04

I think this was documented as a bug my many people before. I will suggest
to see if flushing the dashboard cache  helps and avoid a reboot. (To flush
the cache go to Management dashboard, click on Flush application level

Answer #4    Answered By: Indu Raj     Answered On: Oct 04

I have already tried to clear the application level cache  but this does not

Answer #5    Answered By: Khushi Srivastava     Answered On: Oct 04

We tried that but it doesn't work unfortunately - don't know if other people
had similar problems with flushing though? We had to start/stop services  or
reboot the server. However, even start/stop services had problems so we went
for a server  reboot, advising clients that new users  should be added  in
batch out of office hours.

Answer #6    Answered By: Arti Patel     Answered On: Oct 04

I have had the same issues with adding users  as Greg has outlined below...I
have been looking for a solution to no avail.
Unfortunately, the group  approach will not really work as I have multiple
dashboards/folder with different permissions  and would therefore end up
adding quite a number of NT groups....

Surely, Microsoft are working on this problem  as it does seem to be quite

Answer #7    Answered By: Claire May     Answered On: Oct 04

The groups  approach obviously works because the security console is not
updated when users  are added  to the groups - rather the group  is a
collection of NT accounts or users that have the same role. Thus, there
would be 3 groups; Coodinator, Author, Reader, and users would be added to a
group depending on their sharepoint  role. Katherine's point is well taken,
and is the reason we have decided to just go for batch adding/restart. We
have too many users, all with fairly dynamic roles within sharepoint.

Answer #8    Answered By: Dan Dickerson     Answered On: Oct 04

Flushing the application level cache  does not help. Still get the same
problem. However, for now, since it does seem like a problem, creating
general local  groups (Coordinator, Authors, Readers) and then adding users
to it seems to work. Microsoft states that this problem  was corrected a
while back even before releasing the eval version  but I don't think the
problem has been fully corrected.