Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

.NET Conflicts

  Asked By: Karissa    Date: Oct 02    Category: Sharepoint    Views: 2020

The past couple of months I have been getting this error:

This Windows SharePoint Services virtual server has not been
configured for use with ASP.NET 2.0.50727.42. For more information,
please refer to Knowledge Base article 894903 at

I used the information that the article provided, but that did not
solve the problem. We loaded Symantec Anti-Virus For SharePoint a
couple of months back, and it seems that this problem started close to

I have rebooted IIS, and that is not successful at bring the portal or
WSS sites back up. Typically after a couple of hours, it will
mysteriously begin working.



1 Answer Found

Answer #1    Answered By: Damon Garner     Answered On: Oct 02

I had the same issue after upgrading to Asp.Net 2.0xxx on SBS 2003 with
a custom dns setup.

The Regiis for asp.net 2.0xxx didn't take at first and then using the
administrators guide method for stsadmin.exe didn't work so well either
so I did this:

Copy the first line in cmd prompt and hit enter

Then copy the second line in and hit enter. You can use the second line
replacing localhost:80 with whatever website url you have setup in iis
6.0. such as: www.Ilostmymarbles.com <http://www.ilostmymarbles.com/>

I ran the second line for each website separately and it worked fine. If
your sites aren't coming up for a couple  of hours, it sounds more like
an internet propagation thing and maybe some weird settings in the
hostheader, dns or however your firewall or router or domain pointing is
setup. Are you running SBS 2003 with an out of the box configuration or
a manually configured router as the dns server? Are the sites not coming
up right away from inside the Lan or outside?

You should be able to go into iis 6.0 and right-click/browse any site if
they are running correctly. Lastly, make sure the asp.net 2.0xxx is
selected in the ASP.Net tab in each websites properties tab in iis 6.0
and then in the cmd window run iisreset

"%SystemRoot%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe" -i

"%CommonProgramFiles%\Microsoft Shared\web server
extensions\60\BIN\STSADM.exe" -o upgrade -url http://localhost:80
<http://localhost:80> -forceupgrade

I found this worked.

Didn't find what you were looking for? Find more on .NET Conflicts Or get search suggestion and latest updates.