MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

MOSS Search yields no results

  Asked By: Madhavi    Date: Apr 27    Category: MOSS    Views: 1937

My client has a MOSS 2007 Enterprise box running on Win2003 (32 bit)
Standard. The DB is SQL 2005 on a separate 2003 server.

When I crawl, I get lots and lots of little green dots. It completes
successfully. However, searching from the root site/child site/list level
yields zero results. I'm searching for simple 4-letter and 5-letter words
that I know are included in several list items.

I've checked everything in this list:


...and we're all good. I had to change a few things (for some reason they
had turned off the Search Service) and just to be sure, I ran another full
crawl afterward... but still no search results.

In case it matters, Search was working at some point; a while back Crawl
stopped completing successfully (bizarre error) and after waving a dead
chicken over it this morning, I got the Crawl part running again. Still no
Search results.



9 Answers Found

Answer #1    Answered By: Aastha Patel     Answered On: Apr 27

I ran into this recently.
Try resetting the crawled content:

Make sure the crawl time is configured also.

Answer #2    Answered By: Akshay Gupta     Answered On: Apr 27

but wow, those instructions were terrible (the page
names and sequence didn't make any sense at all; I checked three times just
to make sure it was intended for MOSS 2007). Thanks, TechNet!

I managed to reset the crawled content. Now when I start a Full Crawl, it
finishes in 2 seconds. No errors, though; it just says "Crawled
http://rootsitename" and stops there. The content source has "Crawl
everything under the hostname for each start address" checked, and I even
have a crawl rule to include everything under the site.

Any thoughts?

Not sure what you mean by configuring crawl time. Do you mean timeout
factors, or scheduling? I'm just firing manually right now.

What am I missing?

Answer #3    Answered By: Trinity Scott     Answered On: Apr 27

On your "Edit Content Source" page there is a section "Start Addresses". Is it
populated? It should contain the URL's for mysite, sharepoint site and SSP.

Answer #4    Answered By: Constance Guerrero     Answered On: Apr 27

It does not have MySite and SSP URLs, but it never has; I removed those.
Before I did the "reset crawled content" thing, I was getting lots of
results in the crawl log; now I just get the main site (at the URL listed in
the Start Addresses section).

Answer #5    Answered By: Chandrabhan Konwar     Answered On: Apr 27

Did you try logging into SharePoint as your Search Account to see if they can
access those files?

Answer #6    Answered By: Tina Owens     Answered On: Apr 27

Actually, yes; that was one of the first things I did this morning :) These
are all list items, and the lists are accessible. No weird broken
permission hierarchies or anything like that.

Also -- I think I mentioned this, but it's been a long day -- before I did
the reset, my crawl picked up everything but search  got nothing. Now the
crawl gets only the root URL.

Answer #7    Answered By: Tiana Whitaker     Answered On: Apr 27

Was the bizzare error the 2436 Gather error? If so I will pay you $25 for that
dead chicken!

Answer #8    Answered By: Alice Chandler     Answered On: Apr 27

You mean this one?

The start address <http://servername> cannot be crawled.

Context: Application 'SSP1', Catalog 'Portal_Content'

The specified address was excluded from the index. The crawl rules may
have to be modified to include this address. (0x80040d07)

If so, yes... but I still get it on the other address (not that it matters
since they're both pointing to the same site collection).

Answer #9    Answered By: Lynette Sawyer     Answered On: Apr 27

Yes, that's the one! The address mine craps out on is the Central Admin site.

Didn't find what you were looking for? Find more on MOSS Search yields no results Or get search suggestion and latest updates.