Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

MOSS Publishing Site Quick Lanuch Menu Highlight

  Asked By: Sampat    Date: Feb 17    Category: MOSS    Views: 2291

A MOSS publishing site, in the site there are just some pages. For the
quick launch,I added a heading called Table of Contents, then I
manually added links to the pages under this heading, such as page 1,
page 2, etc.

So the quick launch looks like the following:
View All Site Content
Table of Contents
. page 1
. page 2
. page 3
All pages are in the pages document library, and page 1 is the welcome
page.

Here is the problem. When go to the site, it shows page 1 and page 1
menu link in the quick launch is highlighted with yellow background.
However, if I click any other pages on the quick launch, page 1 menu
link stays highlighted, not the page is displayed. What could be wrong?

On the site nav settings, I have both show subsites and show pages
unchecked. If I have show pages checked. The highlight works but in
the breadcrumb, it show the heading, such as sitename > Table of
Contents > Page 2. and user does not want Table of Contents shows up
in the breadcrumb. This is why I have show pages unchecked. Also Table
of Contents in the breadcrumb is not clickable.

Share: 

 

9 Answers Found

 
Answer #1    Answered By: Janell Camacho     Answered On: Feb 17

I can reproduce the same problem  in my SharePoint environment too.

 
Answer #2    Answered By: Julia Washington     Answered On: Feb 17

A co-worker of mine found out the following:

As before, page  1 is the welcome page. Create another page such as
page1a, with exact the same content of page 1. On the quick  launch,
change the url for page 1 to the url of page1a. After above, there
would be no highlight  on the quick launch, which is better visually.
however, now you end up with 2 pages  with exact the same content,
which can cause maintenance problem  down the road.

Any suggestions how to get around this? Is this a bug in SharePoint?

 
Answer #3    Answered By: Shashwat Takle     Answered On: Feb 17

I suspect that your problem  is because manual links  aren't designed to
be used as a replacement for the dynamic links that are generated by the
navigation system. So when you manually added  links to existing pages
and then turned off show pages  SharePoint still tries to highlight  the
dynamic link  for the page. Try this test and you will see what I mean.
Turn show  pages back on. Now click  on your manual link and you will see
that the page  is retrieved, but the highlight shows  on the dynamic entry
for the page, not the manual one you clicked on. Turning off show pages
doesn't remove these links, it just hides them. The highlighting is
there, but its not visible. Its not a bug, since manual links were
designed to be used to add external references to your SharePoint site,
not internal references that are already available. I don't think there
is a way to get around this other than writing your own custom
navigation control to replace the Quicklaunch. It's the way its
designed.

 
Answer #4    Answered By: Aastha Acharya     Answered On: Feb 17

Yes. I did that test and I agree with Paul said.

But this design really creates some problems sometimes. If "Show Pages"
is turned on, any time a user  creates a page, the page  will be listed on
the left navigation automatically. At our company, the user who creates
the page does not necessary have the permission to change the navigation
(hide this page from the left navigation for this case)

Anyway I have disabled the "Show Pages" for now, but I really miss the
highlight part.

 
Answer #5    Answered By: Glenda Roth     Answered On: Feb 17

Pages that show  automatically in the QuickLaunch will be security
trimmed. Since the pages  library is set to require approval and you can
modify the settings  so that draft pages only show for the original
authors and users with approval authority you can arrange it so that the
dynamic entry only shows  up after the page  is approved, except for the
original author and members of the approvers group. Manual entries are
not security trimmed.

 
Answer #6    Answered By: Jada Clemons     Answered On: Feb 17

I did another test and found it was very interesting.

1, turn on "Show Pages"

2. Create a publishing  page

3. Create an authored link, and link  it to the publishing page  you just
created.

4. Hide the Publishing page inside the navigation settings.

5. Browse the left navigation and click  the authored link, you will see
this manual link is highlighted correctly.

Do you know why the manually links  are highlighted correctly when Show
Pages are turned on and the existing page is hidden?

 
Answer #7    Answered By: Brooke Lewis     Answered On: Feb 17

I don't know, but I would assume that its because "Show Pages" does
something at the level of the SiteMapProvider, while hiding an
individual page  affects only that page. In other words, turning show
pages off does something different from hiding all the individual pages.

 
Answer #8    Answered By: Talia Johns     Answered On: Feb 17

That sounds reasonable. I thought there could be some parameters that I
can tune in the web.config file to modify the SiteMapProvider's
properties. But so far I had no luck.

If anyone knows how to get this problem  solved, please let me know. I
really appreciate it.

 
Answer #9    Answered By: Tera Callahan     Answered On: Feb 17

I end up turning on show pages  option in the navigation settings.

 
Didn't find what you were looking for? Find more on MOSS Publishing Site Quick Lanuch Menu Highlight Or get search suggestion and latest updates.




Tagged: