MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

MOSS 2007 very slow

  Asked By: Mathew    Date: Mar 19    Category: MOSS    Views: 2729

I expect this problem is something I have done wrong but I cannot see
what it is. I am setting up a test service with MOSS 2007. I have three
servers - one, a quad processor machine with 16GB, runs SQL 2005. There
is nothing else using it. A second machine (dual processor 3GB) has the
sspadmin site on it and nothing else. It will run things like Excel
services eventually to try out but at the moment there is nothing on it.
The third machine (single processor, 2GB) is a web front end. So far
there is a blank WSS site and an almost blank portal site on these
machines and I am the only user. They are all connected to a gigabit
network. Now the surprising thing to me at least is that performance is
pretty bad. It takes about 30 seconds to load a page unless I loaded it
no more than a few minutes before. The software is pretty much out of
the box - I haven't done any odd configurations yet.

Is it the machine with 2GB? I suspect a production server would
definitely require more but given that I am the only user and there is
no data other than indexes on the machines I would have thought this
would have been enough. Any thoughts would be appreciated.



23 Answers Found

Answer #1    Answered By: Nagesh Maulik     Answered On: Mar 19


1. IIS logging frequency

2. Turn down logging and error reporting where possible. See the
free download on our premium content site for an .xlst and .bat file to
do this in one fell swoop.

3. Index drive and move it from system if necessary.

4. Indexing frequency and reduce if necessary

5. Profile import schedule

6. IIS App pool settings

7. What do your event logs say?

8. If you have more than (is it 3GB?) memory on your SQL Server,
there is a switch you must put in boot.ini (I think) I would check that
out on the SQL Machine.

9. What is your ping time, in ms, between WFEs, App, and SQL?

Answer #2    Answered By: Jonathan Scott     Answered On: Mar 19

I've run through your check list and
most of them don't appear to be the problem. For example, I run the
profile importer once per week and indexing with the same frequency. I
have the /3GB switch on as well. However, when I checked the event log
(which I must admin I should have checked before I e-mailed but its late
here) I found a whole batch or errors which seem to repeat pretty
regularly. They are:

The application-specific permission settings do not grant Local
Activation permission for the COM Server application with CLSID


to the user COVENTRY\wssapppool SID
(S-1-5-21-965986272-2670324833-3922322202-64404). This security
permission can be modified using the Component Services administrative

I have no idea if this is the cause but since they only come every 2
hours or so they may not be. In any event MS have supplied some
information on how to fix this one so I'll give that a go and tomorrow
have a look at some of your other suggestions.

Answer #3    Answered By: Asia Meyers     Answered On: Mar 19

This is normal behaviour

You are just waiting for the app pools to spin up the first time

Google iis warm up script for scripts to hit the sites for you every morning to
warm up the app pools

Answer #4    Answered By: Shelley Reese     Answered On: Mar 19

Thanks for the very prompt reply. I did wonder if that was the problem
as I think that used to happen with wss v2 as well. However, the strange
thing is that if I visit my blank site it takes about a minute or so to
load. If I close IE and visit the site again it is quick this time but
if I wait for a very short while (e.g. 5 to 10 minutes) it is also slow
again. Should it "forget" as quickly as this?

Answer #5    Answered By: Omar Arnold     Answered On: Mar 19

Check your Application Pool Recycle Settings in IIS Manager. Under the
Recycling tab, check to see when you are recycling the app pool that
hosts the Web Application in question. Usually, it recycles around 2am
daily. But, you can also set it to recycle every n minutes and/or after
a certain number of requests.

In addition, you may also have set it to recycle when reaching a maximum
memory threshold.

Answer #6    Answered By: Christen Roberson     Answered On: Mar 19

I suspect there is something very badly wrong with my installation. I've
already installed it in a virtual server environment and had none of the
problems I am now finding. I noted down everything I did so what is on
the real servers is a copy of what was on my virtual servers. However,
when I look at the event logs on the physical servers they are
absolutely infested with errors. There are many different kinds of error
and they all repeat every few seconds. Every single one has no further
information when I click on the link at the end of the error. I think I
am going to leave it now and start again tomorrow with a big format of
all the disks.

Answer #7    Answered By: Faith Delgado     Answered On: Mar 19

WSS v2 behaves the same way. Anything that has an app pool
behaves this way.

Answer #8    Answered By: Amrita Durgude     Answered On: Mar 19

Yes I did see that happening when I was using wss v2 but this is a bit
different. For example, I visit the home page and it takes about 30
seconds to a minute to load. If I visit it again a few moments later it
is pretty quick. That is what wss v2 did as well. However, if I wait
just two or three minutes and visit it again it is really slow  again.
Wss v2 used to cache things for a bit longer than a couple of minutes.
Every single page is slow including the admin ones so you can understand
how horrible this is. I've been looking at all sorts of problems in the
even logs as well. There are a vast number and a wide range of obscure
errors - well obscure to me. Some of them name SharePoint others are
about dcom but they coincide with me trying to open pages. I guess
something has gone horribly wrong because I didn't have these problems
when I was setting up the same stuff on some virtual servers. I'm going
to start again tomorrow as it is now 1:15AM. Thanks to everyone for
their contributions though.

Answer #9    Answered By: Maricela Conway     Answered On: Mar 19

If the DCOM errors are the ones I'm thinking of the resolution is pretty
easy. It references a specific error that is easy to trace down. Has
something to do with using DCOMCNFG to give your app pool identity
permission to something.

If that's not the issue you're seeing, please paste the text of the
error message here.

Answer #10    Answered By: Vinay Thakur     Answered On: Mar 19

Yes, that's the one but sadly it didn't fix the problem. It's definitely
something I've done wrong because I first installed it on my desktop PC
using virtual server. I wasn't expecting this to be very quick for
obvious reasons but it was okay and good enough to try things out on or
use for demonstrations. However, what I find is that MOSS on the virtual
servers is much much faster than it is on dedicated IBM X series
servers. As far as I can tell the configurations are the same on both
but I suspect they aren't really and the difference is what is causing
the problem. I intend to start again later tonight and rebuild the
servers from scratch. I'll see what happens with that. One thing I have
noticed is that the event viewer is littered with errors and not just
the DCOM ones but when I checked that is also the case on the virtual
servers. I wonder if there is some account that doesn't have the
appropriate permissions for something. Is there a list anywhere of the
accounts that need administrator access for example?

Answer #11    Answered By: Shameka Rich     Answered On: Mar 19

I am guessing the behaviour is like this at all times of the day ?

Is there anything in the event logs as it sounds like iis may be crashing

Answer #12    Answered By: Royce Orr     Answered On: Mar 19

3 days before we also faced the similar issue of server very slow.

Then we figured out that we configured the full search with frequency of 5

Check the shared service Provider and see whether the full search and
incremental search are crawling or not.
If it is still crawling then stop crawling and see whehter your server is up
or not.

Answer #13    Answered By: Laura Walker     Answered On: Mar 19

You will probably have seen from all the other
e-mail that I have stumbled on the problem or at least a fix for the
problem. It seems to have been something to do with the SQL cluster but
I will check the crawl schedule as well.

Answer #14    Answered By: Nina Banks     Answered On: Mar 19

Yes, it was at all times of the day and night. As you may have seen in
other e-mail I have possibly fixed the problem. I must admit that the
event logs are filled with errors of all kinds though so I am not so
sure now as I was an hour or so ago. There doesn't appear to be anything
that suggests IIS is crashing though. Thanks for the suggestion though.

Answer #15    Answered By: Renee Murray     Answered On: Mar 19

Thats OK - I just wondered what could be up with the QL cluster as we do a lot
of that and its worrying if it seizes up like that.

Answer #16    Answered By: Harshini Raju     Answered On: Mar 19

It's the first time I have seen anything like that with the cluster. We
have used it for a WSS V2 site for a year or more and that hasn't
happened before. I'll post if it happens again. Everything seems to be
working fine now and I've failed the service back and forth between the
two servers several times without the problem reappearing.

Answer #17    Answered By: Christop Mcfadden     Answered On: Mar 19

First time loads of a page in sharepoint normally take 30-45 seconds.
As you add users they will tend to extend the lifetime of page
fragements in the cache which will improve the overall performance.

Answer #18    Answered By: Gopal Jamakhandi     Answered On: Mar 19

I think the problem is fixed without re-installing everything.

I knew that it could be slow  the first time I visited a page after a
reboot etc but the problem was that it was almost always slow. I spent
some time this afternoon looking at the servers and especially the
network settings all to no avail. However, someone suggested that
perhaps the problem was related to the SQL server. It seemed to be okay
but just in case I failed it over to its partner (they operate in a
clustered pair) and the SharePoint site immediately went at the sorts of
speeds I would expect. I've just failed it back and it is still fine.
Very very strange but I guess there must have been something up with the
virtual SQL server. We don't use it for very much other than trying
things on so it wasn't that it was busy doing something but it just
seems to have been having difficulty responding to requests.

Answer #19    Answered By: Felipe Osborne     Answered On: Mar 19

I said I would follow up on this problem if I found the answer. Well
here it is. As you may remember I failed the virtual SQL server from one
machine to another and noticed an immediate speed improvement. Even when
I failed it back again it was still okay. It seemed therefore that it
was something up with SQL. However, later in the week I noticed that it
was still sluggish sometimes - not as bad as it had been but definitely
not right. It now turns out that it was not an SQL error at all. A
rather sheepish network engineer admitted on Friday afternoon that there
was indeed something up on our network backbone and he would be working
all day on Saturday to fix it. I had suggested it was a network problem
earlier in the week but as usual I got the standard response from
network people - "I can ping the server so the network is be okay. It
must be your servers". However, it seems this was not correct and they
"discovered" a problem with one of the core switches on Friday afternoon
- only 4 days or so after I reported it! Anyway it's all fixed now
apparently and sure enough response is much more like I would expect and
it wasn't a problem with SQL either.

Anyway, I though I would let you know the outcome in case anyone was
looking at their SQL servers with suspicion.

Answer #20    Answered By: Steve Fernandez     Answered On: Mar 19

Thought I'd use this same thread since my problem
appears very similar.

I have opened a call with Microsoft. Big surprise: they haven't been
at all helpful... just keep asking for more log files.

Issue: Every few days (no pattern I can discern as yet) MOSS will
become basically unresponsive. I have 4 MOSS Web Applications (SSP,
Content, Mysite, Records Center), and the only one that appears
affected by whatever is going on is the Content application.

Root of Content application is completely unresponsive during this
time. Team sites and portals defined with managed paths are slow, at
the start.

Here's the odd part: The first time this happened, it resolved itself
(read: stopped being a problem through no action -I- took) after
exactly 4 hours. Second time it happened, resolved itself after
exactly 3 hours. Because my content portal isn't being used heavily
outside business hours, I don't know if it happened at all in the

OS and MOSS log files appear very empty of relevant information.

Can you tell me what your network admin "fixed"? It might help to
have some ammunition when I go to them.

Answer #21    Answered By: Travis Turner     Answered On: Mar 19

As I understand it there was an issue on the core switches which
resulted in packets being dropped. Apparently the network people had
made some changes to the configs on the switches which caused the
problem. They put the old configuration back and the problem was solved.
However, they don't think it would have affected my MOSS servers though
but then again it all seems to be working now.

Answer #22    Answered By: Noah Carr     Answered On: Mar 19

We are also experiencing some slow  performance, however our problem is
with My Sites (performance everywhere else is fine), when clicking

1) private and public profiles
2) between public profiles for two users

The page does not load on some occasions for 40 seconds, there is no
feedback from IE to sugguest that the page is loading in the status
bar, then the page loads. This seems to be an intermitent problem and
is not a problem for any specific users my sites, it is also a problem
when there are no web parts on the page - which suggests that its not
content related.

Answer #23    Answered By: Skyler Poole     Answered On: Mar 19

Do you have the mysite url in your trusted or intranet site list in IE? And
if so, do you have form authentication on your OWA?

I'm seeing the exact same thing, and I think it has to do with the mysite
domain trying to pass credentials via NTLM to the OWA server but since the
OWA is using form authentication it's timing out. That's just a complete
wild ass guess though.

Didn't find what you were looking for? Find more on MOSS 2007 very slow Or get search suggestion and latest updates.