Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Missing default.aspx file after Report Center site creation

  Asked By: Ashu    Date: Jun 05    Category: Sharepoint    Views: 3901

I've got a user attempting to create a new site using the Report Center template. The site is created but returns a file missing error to the user. Through SP Designer I can see that the folders and files are created EXCEPT the default.aspx

My presumption is a problem with the template - how can I repair the template?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Claire May     Answered On: Jun 05

First try to check if you are able to access the settings page. Replace the 'default.aspx' with '_layouts/settings.aspx'.

Once it opens try to create  a new page and check if that is appearing. Make this as the default  home page of your site.


Incase you really want to repair  your template, you will have to create a new site  template similar to the reporting template. It is a bit tedious job.

My suggestion would be not to touch the original templates.

 
Answer #2    Answered By: Dan Dickerson     Answered On: Jun 05

Finally getting back to this ....

I can get to the settings page and I can open the site  in Designer to view the files. I can browse through the document library and create  pages and sub sites. In fact, it appears that everything is there except the default.aspx file. Whether the System Master Page is set to Inherit or custom I get a file  Not Found error.

I have found that this error  does not occur in all site collections. Can I presume the template  is ok and that there is an issue with the collection then? Or is there some other way to verify that the template is "valid" and contains all of the files?

 




Tagged: