Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Memory question

  Asked By: Anita    Date: Feb 23    Category: Sharepoint    Views: 839

e have a total of 48,000 documents. I installed SPPS on an existing server
and we imported the documents and the metadata using a simple script....I
did not program it but basically it brought in the documents and the
metadata from an outside DB file.

When this server was running the store.exe would use 720,000MB of memory n
task manager...everyone says it uses as much as it can....so I did no panic.

This server became unstable, for other reasons, so I rebuilt it from scratch
and restored the workspace with msdmback.vbs

Now, store.exe, same workspace, all files indexed, never goes above

Why? Did the backup/restore process optimize the workspace? Was the higher
useage a sign of instability?

One reason I am interested in this as we are looking at using the same
system and process for 250,000 docs.....in the near future.



5 Answers Found

Answer #1    Answered By: Jaclyn Gordon     Answered On: Feb 23

There is a consistent measurement you can use for memory  usage as far as the
indexing goes. For every 100K doc versions, the index will use about 128 meg. So
far 250K doc versions, it would use about 320 Meg. I have not seen this
documented, but I have found that for each workspace, it will take about 50 meg
for the first one and 30 meg for each additional one on a server. Other memory
usage fluctuates based on concurrent users and what they are working on.. So, if
you average 4 versions per document, you can assume you will need

1280 meg memory for indexing (1 million doc versions)
plus each workspace (about 30 meg)
plus concurrent user portal needs (don't have a number for this but you have
probably seen this variance on your server already)

As for why it was 700+ before, that could be because it does not start by using
as much as it can, it grows to that amount. The way it does that is that when a
new request is made, it caches it and does not release the memory back unless
some other process needs it. So you may see your 155 grow back to 700+ over the
next week or two.

Answer #2    Answered By: Bhupendra Bajpai     Answered On: Feb 23

I have seen a number of folks that have the same issue, but no one seems to
have an answer:

When I open the Sharepoint administrative tool, I get a message "Unable to
open Sharepoint Portal Server "Servername""

The workspace continues to function and I can access it via the http

One clue is I was messing with the "application setting", "configuration",
"app options", which totally wrecked my workspace. I restored it which
fixed, but now I have this issue...

What is the entry point for the administrative program?
What things have to be in place for it to function?
If I do a simple restore, it appears I will be stuck with the same issue, so
how would I gut the thing and restore? Uninstall IIS necessary?

another clue, when I go to the security tab on the properties of my
workspace (via my network places) I get an error 0x80004005 unspecified
error occurred. When I ok through that error the security shown is
completely blank.

I have tried a repair to no avail.

Answer #3    Answered By: Marianne Vance     Answered On: Feb 23

Unless there is something wrong with the server, that issue is related to how
the PROXYCFG is configured. What is happening is that the Admin program is
attempting to open a connection to the server and the connection is not

Answer #4    Answered By: Aayushman Kanvinde     Answered On: Feb 23

I have also faced the same problem as many of you have.
I had my site created in IIS and was trying to open the Admin Console
but no way it was opening. So i started playing around. In IIS i
stopped my site(default site was running though) and tried to open
the Admin Console again and it opened. I tried to figure out why this
was happening but couldn't find a logical answer to this.
If anybody can shed light on this, will be highly appreciated.

Answer #5    Answered By: Edgardo Atkins     Answered On: Feb 23

Mine, was due to a misconfiguration with IIS I inherited aa settgin to the
default virtual dircetopries....don't tell anyone, but I made a mistake.

Learned a lesson, however, I should have backed up IIS metabase!

Didn't find what you were looking for? Find more on Memory question Or get search suggestion and latest updates.