Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Any luck running prescan.exe?

  Asked By: Garrett    Date: Jun 15    Category: Sharepoint    Views: 1794

I pulled the following files from the following CABs:

- x86\Global\Wss\sts.cab -> PRESCAN.EXE
- x86\Global\Sps\spswfe.cab -> PREUPGSC.XML

...and ran the following command line:

prescan.exe /c preupgsc.xml /all

...and get the following error in the prescan log file:

02/01/2007 18:51:50 Error: Exception while looping through virtual servers.
02/01/2007 18:51:50 System.MissingMethodException: Method not found:
System.String
Microsoft.SharePoint.Administration.SPVirtualServerConfig.get_DefaultZoneOut
goingUrl().
at
Microsoft.SharePoint.PreupgradeReport.Scan.ScanOneVirtualServer(SPVirtualSer
ver curVS)
at Microsoft.SharePoint.PreupgradeReport.Scan.Run(StringCollection
argsList)
02/01/2007 18:51:50 Scan finished with failure.
02/01/2007 18:51:50
===============================Logs===============================
02/01/2007 18:51:50 Log file:
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\PreupgradeReport_633059527084496672_Log.t
xt
02/01/2007 18:51:50 Summary file:
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\PreupgradeReport_633059527084496672_Summa
ry.xml
02/01/2007 18:51:50
==============================Totals==============================
02/01/2007 18:51:50 Number of sites skipped (already scanned): 0
02/01/2007 18:51:50 Number of sites scanned: 0
02/01/2007 18:51:50 Number of broken sites: 0
02/01/2007 18:51:50 Number of webs scanned: 0
02/01/2007 18:51:50 Number of broken webs: 0
02/01/2007 18:51:50 Number of webs using custom template: 0
02/01/2007 18:51:50 Number of pages scanned: 0
02/01/2007 18:51:50 Number of unghosted pages: 0

Any thoughts?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Faith Delgado     Answered On: Jun 15

Turns out there is a bug in prescan.exe where it has a dependency on WSS/SPS
SP2 but doesn't actually check to see if these service packs are installed.

 
Answer #2    Answered By: Alisha Itagi     Answered On: Jun 15

If I were to swag this, my guess is that you're not running  that on a system
that had WSS 2.0 SP2 installed on it.

SP2 added the additional alternate access features, and this error  is noting
that PRESCAN is expecting that method  to be there, but not finding it.

Two ways to check, goto the WSS bin folder<%Program Files%>\Common
Files\Microsoft Shared\Web server extensions\60\bin on that server and look
at the version of STSWEL.DLL or STSADM.EXE, that will give you the version
of the binaries installed

Otherwise, you can go to WSS Central Admin and look at the version noted for
the virtual  servers.

 
Didn't find what you were looking for? Find more on Any luck running prescan.exe? Or get search suggestion and latest updates.




Tagged: