MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Login window pops up when opening office documents..docs..xls..etc

  Asked By: Dianna    Date: Nov 12    Category: MOSS    Views: 8360

We have a MOSS07 with SP1 in our environment and have an issue with opening
Microsoft office documents where when you click on them, it pops up another
window asking you to log in. And even when you log-in, it takes you to the
screen you were at and when you close it, in some cases it opens up the file and
in some cases it is not. It is very annoying and is not a very good user
experience at all.

Twist here is that we have a forms authentication based site instead of windows
authentication. Does anyone know how to fix this? I read alot of people having
this issue but no one seem to have a true resolution. On option that i tried was
'client integration' under Authentication Providers and that actually blew up my
site because it updated the web.config file and deleted all of our custom
settings that were in there.

Any help you can provide would be very helpful. Or if there is a webpart
available that i can use where documents will open inside of a web-part, that
would work too.



12 Answers Found

Answer #1    Answered By: Sheryl Velez     Answered On: Nov 12

check "auto sign me" on the form log  in page before signin on. if that doesn;t
solve the problem, check browser's cookie settings.

Answer #2    Answered By: Alexandra Lewis     Answered On: Nov 12

If you use OOB login  page, ie, _layouts/login.aspx. you should have it, unless
you have customized the page and got it hidden. see this article:


Answer #3    Answered By: Himanta Barthakur     Answered On: Nov 12

We have had that issue. What we found to work  was to set up the SharePoint site
(whatever the Url for the site) as the Local Intranet. Can be done directly on
the desktop on the web  browser. For IE, Tools>Internet Options>Local
Intranet>Sites>Advanced. You'll need to be logged onto the site... simply click
remember password when logging in and then click  ADD on the Advanced tab listed
above. Makes SharePoint the Local Intranet site  and stops the constant log  in
requests when opening  documents from libraries, or changing pages on the site.
I believe this can also be done on the Domain level, but since I'm not the Sys
Admin, I don't know the exact steps to do that.

Answer #4    Answered By: Mansi Revenkar     Answered On: Nov 12

Unfortunately this is an externally accessible site. And we don't have 'Remember
my password' option  enabled because it is an externally accessible.

Answer #5    Answered By: Lizette Mcconnell     Answered On: Nov 12

What version of windows are you running? I ask because there are know issues
with Windows Vista and SharePoint regarding this matter. Also from what Robin
was saying instead of clicking remember password you can add the site  under
Trusted Sites and then click  on Custom Level and scroll down to the bottom and
set it to keep credentials.

Answer #6    Answered By: Rosanna Parrish     Answered On: Nov 12

Out client is not running Vista. They are on XP with IE6 and here internally we
been testing it on XP with IE7 and we are seeing very similar behavior. I went
into 'Authenticated Providers' and removed the option  for 'Enable Client
Integration' and it seems to be working on XP with IE7 and XP with IE6. However,
we are still waiting for client to confirm. I am not sure if the issue  is
resolved just yet but i defiantely hope so because i would hate to have to open
a ticket with MIcrosoft because they take forever to provide  a solution. If you
have any other thoughts or suggestions, please post those.

Answer #7    Answered By: Kalash Karmakar     Answered On: Nov 12

Okay you are faced with what I call an "authentication framework logic error" on
Microsoft's part (it's my fraise and my opinion don't google it you won't find
anything google instead "Using forms  based authentication  with guest account in
SharePoint" or something similar instead). Instead of adding a fourth
authentication mode gear specifically at using SharePoint with a guest mode
option on public facing sites (when extending a web  app to intranet zone) they
only gave you three types of authentications modes (myself and many others have
been faced with the same thing you currently are). When you turn on anonymous
access it limits the permissions of the anonymous users in SharePoint to only
allow them to have read  only permissions on doc libs (right fully so b/c you
don't want just anyone uploading documents  and such to your site  (little things
call viruses, trojans, ect. ring a bell, but downloading is a different story).
So not to rehash what you can find on the web and save my fingers from needless
typing, what you are going to have to do is set up a guest account in your forms
authentication and then hack or trick SharePoint into automatically logging in
any user not logged in with the guest account thru your forms auth, and then add
this account to SharePoint with the permissions you want then the users can
download the docs  with out a log  in box.

Simply put (and to save my fingers from re-hash hell) you need to go to the link
I provided below; read the info, download the source code and then follow these
steps in implementing them, good  news for you is you already have forms
authentication working, so you are half way there!!! (NOTE: I would read it a
couple of times before starting just so you understand the concept and make sure
its what you are looking for there is three parts to the serious)


Answer #8    Answered By: Mauricio Tanner     Answered On: Nov 12

I will give it a go. Thank you very much for the info.

Answer #9    Answered By: Gina Freeman     Answered On: Nov 12

If that doesn't work  let us know. Our development team has worked
side-by-side with David Mowers and recompiled new code that rectifies
the problems associated with using client integration  and forms  based
authentication. Keep in mind that disabling client integration is not
going to provide  the ability to upload multiple documents, not allow you
to open  a document library using windows explorer and will remove the
Edit Using Microsoft Office Word/Excel/PowerPoint/etc.

However, we have worked to successfully add these functionalities and
recompiled the ECTS.MSI file. The fix  is proprietary but will ensure
proper functionality. We have not yet offered the code to the public as
other vendors are charging $5000+ for packaged solutions.

We would be happy to accommodate your organization with a working
solution at your request.

Answer #10    Answered By: Tyrell Nash     Answered On: Nov 12

My company only uses external sharepoint wss3 and moss2007, so we have this
issue resolved by setting the site  to local intranet for people  with vista and
trusted site for people with xp, should be same for ie6-ie8, though we haven't
tried too much with ie8 yet, seeing as how some www sites don't seem to work
correctly in ie8.
By the way, there are times you do need to reauthenticate, but it is diminished
dramatically with these settings.

Answer #11    Answered By: Alex Choroshin     Answered On: Nov 08

Hi Dianna,
We opened a service request and got a solution from Microsoft.
We got 3 possible ways to solve this issue.
Check out my article: