Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Login Issues

  Asked By: Aurelio    Date: Mar 04    Category: Sharepoint    Views: 1431

I have 2 sharepoint sites, one internal and one external.

On the internal site, I can go open a document in word and it comes
right up.

On the external site, whenever I go to open the document in word, it
prompts for a password, even though I just logged in to the site a
couple minutes ago.

Any idea how to get around this?



8 Answers Found

Answer #1    Answered By: Kyla Eckert     Answered On: Mar 04

Is the document  you are opening in a SharePoint document library?

When you log into SharePoint, you are not necessarily logging into a
domain. You may find that the domain is protecting the Word document
or even some file that Word needs to run.

Maybe the document itself refers to some domain resource?

Answer #2    Answered By: Megan Martin     Answered On: Mar 04

The document  itself is withing the sharepoint  document library.
Since it is a completely external  site, this machine has no links or
access to the internal  domain for security reasons. So this leads me
to believe it is still a sharepoint setting.

Answer #3    Answered By: Donta Kirkland     Answered On: Mar 04

Its a security "Feature" and I agree it is a hassle. There may be one way around this though. Try adding your site  as a trusted domain in IE. That may help. When you log in the first time after you open  a word  doc your credentials are cached as long as you keep the document  open. So no this isnt a sharepoint  setting.... this is a mixture of passing IIS credentials to access the site then having office take over and require its own credentials.. There is a document regarding this out there somewhere.....

Answer #4    Answered By: Cade Velazquez     Answered On: Mar 04

One thing you can try is as follows:
If you open  a word document  on the external  site you will be prompted for a username and password... this is due to an ISAPI filter if i remember correctly. If you dont want to get prompted again simply open up the first word  document and leave it open but minimized... you can open any other subsequent word doc and you wont get prompted during the logged  on session. You will need to do the same for Excel and so on.

Answer #5    Answered By: Ariana Christensen     Answered On: Mar 04

Is there a way I can set it up so I don't get prompted at all? I am
not sure why it works like this on the internal  site but not the

Answer #6    Answered By: Darrius Whitfield     Answered On: Mar 04

As far as I understand, When you download the word  document, it opens in Word, but the document  has meta data within it that makes the Word application contact the server for the information for the Task pane. Since your credentials were for your browser, Word is not able to reuse them automatically and ends up prompting you again for credentials. Then as long as you have an instance of Word open, it will send your credentials automatically for the next document.

The reason this doesn't usually happen Internally is because most configurations use integrated security - which logs you in automatically when you are logged  into the domain.

Answer #7    Answered By: Adrienne Greene     Answered On: Mar 04

Most of the multiple login  issues are Internet Explorer issues, not SharePoint.

If a site  is listed in the Intranet zone in IE, then IE will pass through your current credentials from the OS. If it is listed in the Trusted zone, IE will always prompt for credentials assuming that you will want to know when your credentials are being forwarded to a web site and assuming that the current OS credentials are not sufficient. Office applications use the same zone information when accessing web sites  as IE. It seems that the authentication packet sent to IE from sharepoint  is only valid for IE and not for Word and the credentials are not automatically passed through for any zones except Local Intranet.

Answer #8    Answered By: Joshuah Huber     Answered On: Mar 04

If it is running on the Intranet Zone in Internet Explorer you will have
a different experience than if it is running in the Internet Zone. On
the client browser, you can either change the way that you are prompted
for credentials or add the domain to your Trusted Zone.

It you need more specifics on how to do either of these options, just

Didn't find what you were looking for? Find more on Login Issues Or get search suggestion and latest updates.