Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Large file upload to Document Library fails.

  Asked By: Jackie    Date: Feb 01    Category: Sharepoint    Views: 16765

Regardless of the fact that uploading 130MB files to your document library is perhaps misguided, I am attempting to upload a 130MB PDF to my document library, and it fails with this message:

The form submission cannot be processed because it exceeded the maximum length allowed by the Web administrator. Please resubmit the form with less data.

I googled the message, and got a link to this KB article: support.microsoft.com/default.aspx which says I need to update this tag in web.config:

<httpRuntime maxRequestLength="51200" />

I figured that a 200MB max upload was more like it, so I changed the offending tag to this:

<httpRuntime maxRequestLength="205600" />

(since 200 * 1024 = 205600).

Remembering from my ancient asp.net training that changes to web.config cause the app to be reloaded automatically, I went to the document library directly without running IISRESET and attempted the frankly questionable huge upload again. It failed.


Then, I went to the document library and attempted the frankly questionable huge upload again. It failed.



2 Answers Found

Answer #1    Answered By: Deonte Stein     Answered On: Feb 01


Increase the maximum upload  size

1. Click Start, point to All Programs, point to Administrative Tools, and then click SharePoint Central Administration.

2. Under Virtual Server Configuration, click Configure virtual server settings.

3. On the Virtual Server List page, click the virtual server you want to change.

4. On the Virtual Server Settings page, under Virtual Server Management, click Virtual server general settings.

5. Under maximum  upload size, type the maximum file  size (in MB) that you want to allow to be uploaded.

6. Click OK.

If IIS is timing out when you upload large  files, you can configure the Connection timeout setting in IIS to allow more than the default 120 seconds (2 minutes).

Tune the IIS connection timeout

1. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

2. Right-click the virtual server you want to configure, and then click Properties.

3. Click the Web Site tab.

4.In the Connections section, in the Connection timeout box, type the number of seconds you want IIS to wait before timing out.

5. Click OK.

Answer #2    Answered By: Stephon Valentine     Answered On: Feb 01

I had a vague memory about a max file  upload size setting somewhere in sps or wss, but I couldn’t find it in the <ahem> user-friendly admin pages.

I followed your instructions up to step 3, but I kept getting a popup when I chose my server (http://whatever), and I didn’t bother to read the pop-up (of course).

Perhaps I should also mention that I applied WSS sp1 after the creation and extension of the http://whatever portal.

But see if you can tell what I needed to do to see the settings page for the site “http://whatever” below (here’s the listing on the Virtual Server Lists page):

To perform administration tasks for a virtual server, click the virtual server name.

Name URL Version
Default Web Site http://whatever:8080/ Not Installed Extend

Project 2003 Server Wss Site http://somehostheaderurl/

Windows SharePoint Portal Server http://whatever/ Upgrade

I’m sure you see the problem. The http://whatever portal wss extensions were pre-sp1, and I couldn’t manage the virtual server until they were upgraded, which I did by running:

stsadm.exe –o –url http://whatever.

Then I could continue your instructions from step 4 below, and after increasing the max upload  size, I can and did finally upload the huge PDF.

Didn't find what you were looking for? Find more on Large file upload to Document Library fails. Or get search suggestion and latest updates.