Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Installing VS Workflow errors

  Asked By: Courtney    Date: Dec 16    Category: Sharepoint    Views: 1258

I've been having a lot of trouble with Workflows. I have build a
few basic workflows using the "Sharepoint Sequential Workflow" and
installed them successfully to my server. When I add them to a
Document Library I get the initiation infoPath form correct. When I
start the workflow on a document I get the Initiate form also. When
I submit it I get the same "The workflow failed to start due to an
internal error. " message.

I have downloaded several barebones workflow also and they all seem
to fail at the same point. I have downloaded and installed
the "Skeleton Workflow" from http://www.burroak.on.ca/wordpress/?
page_id=152. It has no InfoPath forms, it gives me no errors but
never runs.

We have never had a workflow work on this server. My attempts are
the first we've tried. So I don't know if there is a configuration
problem or something we need isn't installed. I am able to add the
Workflows to the Document Libraries so it seems like it understands
them. Any input would be of great help.



3 Answers Found

Answer #1    Answered By: Christian Waters     Answered On: Dec 16

What happens when you attempt to start  the "out of the box" Approval workflow  on
document  in a standard document library? If this fails, you may want to start
with restarting the WSS timer and SP Admin services. However, having said that,
I had this problem earlier this week and I was never able to get it resolved.
In addition, I couldn't get any backup jobs to run. I ended up recreating my
virtual development environment. It was quicker for me to do that than mess
around anymore than I already had troubleshooting.

Incidentally, if you're developing in virtual environments, make sure you use
base images and/or snapshots. They'll save you hours, if not days, of time when
something does go wrong (and it will).

Answer #2    Answered By: Virendar Bahudur     Answered On: Dec 16

Thanks for the suggestions. My development box was setup before I
came along and none the out-of-the-box workflows  are installed. I
ended up downloading the Virtual PC "Litware Demo" Sharepoint server
and trying my workflow  on it. It worked. So I guess the problem was
with my server  all along. I think I'm going to blow it away and build
my own Dev Server. That way I'm not inheriting any old issues.

Answer #3    Answered By: Sierra Beck     Answered On: Dec 16

Following blog entry shows Custom Field Type where you specify who has the ability to enter data in a textbox (see
It works extremely well, but no source code was provided.

I am also interested in a private/secure drop-down and a private/secure
date. Does anyone have any good tips on how to do this?

Didn't find what you were looking for? Find more on Installing VS Workflow errors Or get search suggestion and latest updates.