Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Installation problem in Moss

  Asked By: Ronald    Date: Oct 05    Category: MOSS    Views: 690

I am installing MOSS once again. Having done it a number of times now so
I was surprised to get an error during the configuration phase on task 3
of 8. It claims that the HOSTS file is missing but this is a lie. It
most certainly is not missing. In fact I can copy it, delete it, create
it, move it and edit it all as the setup user. In fact I have given
everyone full control of the directory that HOSTS is in and still the
configuration thing claims the file is missing. Does anyone know how to
fix this? I have searched the web and the advice there is create the
file but I can't do this since it already exists.

Share: 

 

9 Answers Found

 
Answer #1    Answered By: Ciara Collier     Answered On: Oct 05

Could it be a server configuration  of the %SYSTEM% Path.

It really sounds like this is more a windows problem  than a MOSS problem

 
Answer #2    Answered By: Keenan Whitehead     Answered On: Oct 05

Thanks for the suggestion but sadly I don't think that's it. It shows
the full  path to the file  in the error  and the %SYSTEMROOT% variable is
set to C:\windows. I've been browsing around some news groups and it
seems a lot of people have had this problem. I haven't come across a fix
yet though.

 
Answer #3    Answered By: Trisha Wheeler     Answered On: Oct 05

We've reinstalled our pilot test server here several times  as well also with
inconsistent results. Install and search services won't start but everything
else works okay. Uninstall reinstall: services start but now web  apps won't
work. Delete web apps and recreate them using the exact same settings, this
time they load okay in the machine name context but won't use the host
headers for AAMs that worked fine in the original install.

I'm mildly concerned.

 
Answer #4    Answered By: Dameon Dejesus     Answered On: Oct 05

Every installation  I've done has produced a different set of
errors and problems. I think there are big problems with the
installation process that Microsoft need to give some attention to. This
particular installation was actually a training session for a couple of
colleagues now that I thought I had it sussed. I didn't even get to the
point where I could do some MOSS configuration. They were not very
impressed. I've searched around news groups etc and it seems this was a
common problem  in some of the beta releases. However, the only suggested
fix which it is claimed will work (and that only on VMs) is to reinstall
the operating system entirely. It's a pretty poor show that randomly
installation of MOSS will require a complete reinstall of the OS as well
but I'll give that a go now as nothing else seems to work. I wouldn't
mind if this was a beta release but it isn't and I would expect the
installation process to work reliably even if nothing else did.

 
Answer #5    Answered By: Tejaswani Barve     Answered On: Oct 05

It's not a problem  with the Install program. The problem is
uninstalling an install that didn't complete successfully. Since the
previous install wasn't successful the uninstall doesn't come out
cleanly either. Doing a re-install several times  on the same box simply
compounds issues from earlier installs. If the installation  fails the
first time I've seen lots of products from companies other than MS that
can't be re-installed without being sure you have a clean install of the
OS. You should always do a full  backup before installing  a new product.
That way if you make a mistake you can restore back to the starting
point and then try the install again.

 
Answer #6    Answered By: Harshita Padwal     Answered On: Oct 05

I have done many installs on the same machine with
uninstalls in between without this problem  before although I have had
lots of other problems even after I have reinstalled the OS as well. I
do have an image (using ghost) that I use to create  the machine again
which is what I am doing now so that was lucky:-). In fact  I have images
for all our servers. We thought that would be a good idea except that
most of the older servers only have USB1 ports on them so it's pretty
slow:-(. Nevertheless there are a lot of people having problems
installing SharePoint which seem to be down to the install process some
of which are intermittent but others are constant. For example, once it
is all installed there is a nice task  list which leads you through
further configuration  steps. I thought that was really nice except that
some of the links just go to pages that can't be found. Not too serious
I guess but just an annoyance. Last install I did when I picked the link
to check the installation  it told me that there were different services
running on each of the front end servers. Useful information if I
actually had two front end servers but at the time I only had one. I've
not had that before though even though the hardware is the same each
time. Lots of little niggles like that. I am sure they will all be fixed
when SP1 comes out. Some of the permissions and on various windows
components that seem to get set sometimes but not others. A Google
search usually reveals how to fix it but then again why does it either
not work at all or work every time. In UNIX terms if I do a "chmod 755
XYZZY" it works every time and if I don't do it, it never works. It all
seems very odd.

 
Answer #7    Answered By: Jennifer Jones     Answered On: Oct 05

The account your doing the install in is an admin on the box I assume? I ran
into a similar problem  and I didn't have proper permissions on the install,
updating the account got me through with no errors, This isn't best practice
but anything to help troubleshoot.

 
Answer #8    Answered By: Annie Norris     Answered On: Oct 05

Thanks for the reply. I'm afraid it is. It's in the Local Admins group.
I suspect it is something else that is wrong and the error  is just
misleading. In any event having exhausted everything else I am now
rebuilding the server from scratch with a new install of the OS. I
suspect this will fix this problem  but there will be others that appear
this time round I guess.

 
Answer #9    Answered By: Chadd Hahn     Answered On: Oct 05

I have reached the end of my tether with this SharePoint stuff. Having
reinstalled the operating systems yet again and installed SharePoint yet
again I now get a completely different set of errors. When creating the
shared service providers as I have done about a dozen times  before it
now seems to work but when it has finished successfully according to the
web page there is now ssp admin page. The application pool is there but
no page or site. I don't really want to spend the evening reinstalling
servers yet again. Is there any way to get back to the point similar to
the point when moss  is first installed. I.e. Can I delete  the SSP? I
know I can create  a new one and I have done that and made it the default
but that didn't help? If I just delete the databases will that help? I
suspect not! I know I can't uninstall SharePoint because that doesn't
work either. If it is the case that it requires a reinstall of the
operating system then I am going to give up on SharePoint and leave it
until Microsoft have fixed all the errors in the installation  process.

 
Didn't find what you were looking for? Find more on Installation problem in Moss Or get search suggestion and latest updates.




Tagged: