Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Install failed - spsclisrv with code 0x80070641

  Asked By: Damien    Date: Apr 24    Category: Sharepoint    Views: 1221

I now have the need to restore a single file finally, so I started to bring
up another server I could restore an msdmback.vbs-created file to and grab
the document out of there. We don't use any of the SPS-aware backup apps
(yet). We use Legato and I haven't seen if they have one yet.

So I went through the prereq's, started remote registry, installed sp3 (was
on sp2), installed SMTP, made sure virus control wasn't running etc... and
tried to install. I get a generic error that it couldn't install.

I check the eventlog:

[09/06/02,18:28:13] SharePoint Portal Server: LaunchProcess,
(null)\msiexec.exe: Process exit code is 0x80070641!
[09/06/02,18:28:13] SharePoint Portal Server: LaunchProcess,
(null)\msiexec.exe: Process exit code is 0x80070641!
[09/06/02,18:28:13] SharePoint Portal Server: ***ERRORLOG EVENT*** :
CPkmSetupComponent::InstallMSIPackage, MSI Package (spsclisrv) setup failed
with error code 0x80070641. Command=msiexec.exe. Args= -i "C:\Program
Files\SharePoint Portal Server\Bin\spsclisrv.msi" /q -l*v "C:\Program
Files\Microsoft Integration\SharePoint Portal Server\Logs\spsclisrv.Log"
[09/06/02,18:28:13] Setup.exe: ISetupManager::RunInstallFromList(IP_INSTALL)

and the spsclisrvlog shows:

MSI (c) (28:44): Windows Installer proxy information not correctly
MSI (c) (28:44): Failed to connect to server.
MSI (c) (28:44): MainEngineThread is returning 1601

I double-checked my pre-req's and found that -- oops - Trend's Serverprotect
WAS running after all, I just didn't see any systray icon like normal. So I
back out the install, turn off Server Protect and try again, and it still
doesn't work.

I'm installing this via Terminal Services, just like I did my main
installation (Hey, Bill says I can on p132! :) I also searched for this
Windows Installer proxy info stuff and didn't find anything worthwhile. I
didn't find anything on that exit code, either.

I'm stumped. Anybody have a suggestion other than trying another box before
my user goes crazy without his files?



3 Answers Found

Answer #1    Answered By: Marianne Vance     Answered On: Apr 24

I guess it could be an issue relating to SP3.

Answer #2    Answered By: Aayushman Kanvinde     Answered On: Apr 24


I tried it from another server  and install  worked fine. New server isn't
SP3, and I wasn't Terminal Service'd in, but install was from same install
source. So I suspect either SP3 or the Term Serv piece. If I get a chance,
I'll try installing  on same server as before but on the console.

The server from before has some other stuff installed  on it, like Aelita,
SQL Server and the Microsoft Base Security Scanning Tool. I also had to
install three "Automatic Updates"-notified updates about 5 times in order
for them to install.

Answer #3    Answered By: Edgardo Atkins     Answered On: Apr 24

Another update:

I've recently learned that I've been unable to install  or remove anything on
that box, and I get generic  Windows Installer problems on it. I found  MS
article Q260404 and that is the course I'll take to try to fix the problem.
Just thought I'd document  for all.

Didn't find what you were looking for? Find more on Install failed - spsclisrv with code 0x80070641 Or get search suggestion and latest updates.