Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Infopath Contact Selector issue

  Date: Oct 13    Category: MOSS    Views: 1502

I'm having a problem mapping an Infopath field to a user field selected via the
Contact Selector control. I've been following this walkthrough:

www.myriadtech.com.au/.../Post.aspx?ID=20

I'm able to connect to the server and look up users but I can't seem to get any
of the user data to display in a text box. It seems like I'm missing something
obvious as this doesn't seem to be a very complex operation. Anyone have any
suggestions?

Share: 

 

1 Answer Found

 
Answer #1    Answered On: Oct 13    

When I first tried this, the problem I had was that it is not clear what to put
in the Name is equal to x (where x is Department or Manager), whether to include
or not include the single quotes around the x. The picture is too small to be
sure. So I tried it with single quotes, and no go. The form loaded properly, but
the Department and Manager text boxes remained empty. When I removed the quotes,
the system put quotes around Department and Manager. That worked. Here is what
it should look like:
Value[Name = "Department"]

You could paraphrase this as: Give me the value of the field whose name is
"Department"

I've tried this in InfoPath 2007 and InfoPath 2010, and it works more or less
the same way in each (in InfoPath 2010, you get to Rules in a slightly different
way, but it is the same procedure once you get to the Rules for a textbox.

 
Didn't find what you were looking for? Find more on Infopath Contact Selector issue Or get search suggestion and latest updates.




Tagged: