Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Incorrect version to restore

  Asked By: Betsy    Date: Oct 07    Category: Sharepoint    Views: 2488

I'm trying to do a disaster recovery restoration of a sharepoint site, but each
time I run the stsadm command, i get this;

Your backup is from a different version of Windows SharePoint Services and
cannot be restored to a server running the current version. The backup file
should be restored to a server with version
'1784835900.544498533.1701869940.1766662' or later.

Is there a way I can find out what version is running on the target server and
what patches and fixes are required to bring it up to the right version ?



8 Answers Found

Answer #1    Answered By: Geraldine Slater     Answered On: Oct 07

The command  line i'm using is this;

stsadm -o restore  -url http://companyweb -filename
\\backuplocation\foldername\00000000.bak -overwrite

Is there any way of knowing how I can bring my sbs2008 server  to the right
version level to get this thing installed?

Answer #2    Answered By: Gail Richmond     Answered On: Oct 07

You mentioned earlier that you had catastrophic backups. You cannot
restore the backup  that way. Please use the instructions I sent out
earlier to restore  that database.

Answer #3    Answered By: Ramona Solis     Answered On: Oct 07

you said "As long as all your versions
are right". Given that, and that mine appear not to be, don't my versions need
to be fixed before I do the import ?

I've found a site  of sharepoint  updates and their versions but it doesn't go up
to the version  numbers I'm seeing in the command  prompt.

Answer #4    Answered By: Harvey Blankenship     Answered On: Oct 07

The reasons your versions are all wacky is because you're trying to
restore a Database backup  with a method where STSADM is expecting a
completely different type of file. It looks into this file (which it
thinks is a site  collection backup) for the version  to make sure it's
safe to restore. It gets back garbage because the file is the wrong type
of file. It's a database backup, not a site collection backup.

Trust me, follow the instructions I gave you before. Humor me and try

Answer #5    Answered By: Xiomara Blanchard     Answered On: Oct 07

You can't access MSDEE (the embedded SQL server  included in SBS2008) from a
management window, at least so i'm told. Hence why we had stsadm  backups in the
first place.

I've tried pointing stsadm at almost every file we have in the sharepointbackup
folder (maybe 30 or so) and they all report the same error about versions.
Surely all the files cant be returned the wrong data, one of them has to be the
right file to get the backup  restored, unless the versions are wrong (though
according to all our records this server has more updates installed for the OS
and certainly the same ones for WSS).

Lets say that I am trying the restore  the right way, and the info being passed
to sharepoint  is valid, and that the version  of WSS is indeed wrong, is there
anyway to find out what patch brings WSS up to what version number ?

Answer #6    Answered By: Rosemarie Cervantes     Answered On: Oct 07

The problem may be the other way around. It may be that your server  has
been upgraded with service packs or updates since the backups were taken.
This is the kind of error you will get when trying to restore  a backup  from
a previous version  to a later version of WSS or MOSS.

Answer #7    Answered By: Manan Kadu     Answered On: Oct 07

If the files are in a folder starting with "SPBR" you CANNOT using
"STSADM -o backup  -filename" to restore  them. It cannot be done. They
are the wrong kind of file. You'd have as much luck trying to open them
in Word or Adobe Illustrator. If you want to use STSADM to restore them
you need to use "STSADM -o backup -directory" to do it. They aren't all
the wrong version, they're all the wrong type.

I've never used SBS, but I have been able to use SQL Management Studio
to get access to the WID databases that a Basic Install (yuck) of WSS
gives you. Point it at \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query
<file:///\\.\pipe\MSSQL$MICROSOFT%23%23SSEE\sql\query> , without the
quotes on the local box. If you don't already have SQL Management Studio
installed try downloading it from here,
e3d-94b8-5a0f62bf7796&displaylang=en I *think* that's where I got it
when I had to do this. I'm not 100% sure though, it's been a while. Once
you get that set up you should be able to use SQL Management Studio to
restore those .BAK files as databases.

You may also be able to use the command  line tool "osql.exe" with the
SBS WID instance, though I've never tried.

Answer #8    Answered By: Tonia Franco     Answered On: Oct 07

To be able to do a disaster  recovery, you need exactly the same versions
in source and destination. For the database restore/attach Todd sent,
you need the destination to be the same product (e.g. MOSS2007, WSS3,
SPS2003, WSS2, etc) and for the destination to be the same or newer. If
the versions aren't the same you will be forced to attach using stsadm
which will automatically upgrade the database to match the destination

Didn't find what you were looking for? Find more on Incorrect version to restore Or get search suggestion and latest updates.