MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Inconsistent Alert Results on MOSS 2007

  Asked By: Jay    Date: Sep 09    Category: MOSS    Views: 8935

I setup two alerts on the same MOSS top-level site, one with
Announcement and the other with a LInk list. They are all immediate
alerts and I received emails telling me both alerts were set.

When I added new entries to both of them, I only received
notification emails regarding changes made to the Announcement, but
nothing from the link list.

This is a upgraded MOOS 2007 from SPS 2003. Alerts are not working
consistent throught out sites, some of them work as expected and some
of them were silent all the time. MOst of them in either categories
are new alerts created in MOSS.

I tried to find some information but so far only saw other users with
similar issues. Any help is appreciated.



4 Answers Found

Answer #1    Answered By: Alice Chandler     Answered On: Sep 09

I have this resolved and it turned out that too many records inserted
into Event Loga nd Event Cach tables would crash this feature.

If anyone would like to know more details, please let me know and I
will post here.

Answer #2    Answered By: Lynette Sawyer     Answered On: Sep 09

The hosting company we're using was having
problems and never fixed them. I wanted to upgrade from 2.0 to 3.0,
but I won't do it until they've resolved their issues w/ alerts.

If you can explain what exactly happened and what you did to fix,
I'll pass along the details to the hosting company. Then, HOPEFULLY,
they'll fix this and let me upgrade successfully!

Answer #3    Answered By: Alisha Itagi     Answered On: Sep 09

Here is the details. When I noticed alerts were not seding out at all
and only the first email notified user alerts were created, I did some
search on line. There are some tables you have to check to make sure
these alerts are created.

Since the first email was send out when alerted created, so out going
email settings were correct. So I turned my attention to the Eventlog
and Event Chche tables.

From what I understood, when an alert  was triggered, a new record was
added to EventCache table first. When email sent out, then copy this
record to EventLog table.

In the past 3 weeks, one of the major user's personal site inserted
more than 400K raws into EventLog table and more than raws to
EventCache. It's like every 20 to 30 seconds this site created a new
record to both tables.

After I noticed the activities, first I made changes to stop that
personal site to generate this not real even records. Then I started
adding alerts to different sites for testing. The results  were very
positive and looks like it's back to normal now with immediate or
other type of alerts.

If you know your settings are correct, crawling is on and at least one
full update was completed, timer is up and running and you did receive
the first email when alert was created, you may want to check the
tables for more information. You may have different findings and
hopefully my story would help.

Answer #4    Answered By: Gretchen Stokes     Answered On: Sep 09

I would like the details, please.

Didn't find what you were looking for? Find more on Inconsistent Alert Results on MOSS 2007 Or get search suggestion and latest updates.