Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Incoming email setup

  Asked By: Sade    Date: Mar 04    Category: Sharepoint    Views: 7395

I am running sharepoint services 3.0. I am trying to get a document library
to accept emais. I have followed the white papers from MS, however I am
getting an error.

Here is what I am doing:
1) set up the document library
2) go to settings, document library settings, communications, incoming email
3) on the incoming emails settings page: choose yes for allow to receive,
give an email address and press OK.
4) After press OK I receive the following error: Go back to site ERROR.
Error in the application.



5 Answers Found

Answer #1    Answered By: Peter Peterson     Answered On: Mar 04

If after clicking OK you receive  ‘ERROR IN APPLICATION’

This is usually caused by a permissions error. Check the troubleshooting
section at the end of the white  paper for some suggested things to check.
You may also need to check the logs of your moss servers, active directory
and exchange though to try and track down the exact cause of the
permissions error.
You may also get an error  due to an incorrect location or typed mistake for
the Organizational Unit

Based on the description, it appears that the issue lies in the incoming  
email configuration. Either some parameter is not correct or in Active
Directory appropriate delegation is not set  correctly.

When you E-Mail enable a library  in a site  it will create a new contact in
the OU we specify for the AD. Therefore it makes sense to have an OU
dedicated to MOSS2007 list e-mail addresses.

Note – It is the account configured as the sharepoint  Central
Administration application  Pool in IIS that created the contact object in
Active Directory, make sure this account his write access to the OU.

1. It is the account configured as the SharePoint Central Administration
Application Pool in IIS that created the contact object in Active
Directory, make sure this account his write access to the OU.

On a Domain Controller Open Active Directory Users and Computers in the
administration tools and create a new Organizational Unit under your main
domain name. In my case I used the OU name sharepointdl in the domain

At this point we can new delegate control to the Central Administration
Application Pool account to have Write access to the OU.

2. Click Next on the Wizard
3. Click Add to select the Central Admin Service Account from AD
4. Click Next
5. Tick ‘Create a Custom Task to Delegate’
6. Click Next
7. accept  the default setting for the next page  
8. Click next
9. In the permissions box select Read, Write & Create All Child Objects
10. Click Next
11. Click Finish

SMTP Service must to be running  on one of the SharePoint Server. SharePoint
does not support remote SMTP for incoming email. This is because Timer
Service requires to pick the email  message from the drop folder.

The SMTP address  mentioned in the Central Administration > Operations >
Incoming E-Mail settings  should except emails  from your exchange or the
mail Server.

There is contact created in AD for the address which you specify in the
document library email settings. Insufficient Permission on AD OU can cause

Allow Creation of distribution groups. If you want to allow Site
Administrators to create E-Mail enabled distribution groups in Active
Directory for their Site Groups then leave the default to yes and then
select the approval setting for the DirMan service. By using approval the
Site Administrator may be able to create a mail address for the Site Group
but until a farm Administrator approves the new group it will not be
created in AD.
To Approve the Site Groups mail enabled distribution group go the
SharePoint Central Administration – Operations – Topology and Services –
Approve/ Reject Distribution Groups.

Check following:

* Ensure that the Central Administration Application pool account and the
SharePoint Timer Service account are using the same service account. THIS
ONE IS IMPORTANT. A lot of errors stem from these accounts not being the
same DOMAIN service account.

* Make sure the above account has access rights to all files on the server
used by incoming mail such as the sharepointemailws.asmx file on the Moss
server that is receiving the incoming mails. Alternatively make these
accounts local administrators on the web servers receiving the incoming mail

* Make sure the app pool account for the web application you are trying to
mail enable is running as the MOSS Administrator account you are running
Central Administration under.

* Grant rights to the OU you have created in AD to the app pool account you

* Create a SMTP send connector in Exchange to deliver mail to
machine.domain.name where your MOSS SMTP service is running.

* Make sure the account that is running the SharePoint Timer Service has
delete rights to the drop folder or you will receive duplicate E-Mails

* When using Outlook 2003 may need to send the attachment as a Uuencode or
Binhex format in order to get the attachment listed separately in the List
Library. Also see this MS article for another workaround for adding two
attributes to the contact in AD

* If you have installed Forefront security for SharePoint then you may
encounter a problem where the E-Mail will arrive in the drop folder and
then disappear without reaching the document  library. This MS article
explains the way to fix this. http://support.microsoft.com/kb/934285

* If you have used permissions on the document library to control who can
send the process is based on the header of the E-Mail , it is then checked
against the users who have rights to the list or library.

* If you see content in the document library that is assigned to the system
account it means that the document library has treated the incoming mail as
an anonymous users due to not be able to resolve the name in the list of
users with rights to submit mail. You will have to allow the library to
accept mail from all senders to see this.

* When sending to a calendar list to be sent correctly send as a .vcf file
from a new appointment or meeting request in Outlook

Answer #2    Answered By: Kalyan Pujari     Answered On: Mar 04

I have a couple of questions:
1) you are mentioning MOSS2007, I am running  SharePoint Services 3.0...does
this matter for what I am trying to do?
2) How do I find out what the Application pool account is? Is there a way
to verify?

Answer #3    Answered By: Isidro Berger     Answered On: Mar 04

Incmoing email  works pretty much the same way in WSS also.

The best method to find out Farm Account being used is Services.msc >
locate "Windows SharePoint Services Timer" service and check the account
from it's properties.

To check other application  pools for sites you can go to IIS and check
Application Pools there

or use SPSFarmReport http://spsfarmreport.codeplex.com (A must have
SharePoint tool which lists all SharePoint account in HTML page  along with
other useful info)

Answer #4    Answered By: Schuyler Le     Answered On: Mar 04

I have confirmed all of my permissions and everything
you have given me. However, I am still receiving the error. Also, I am
running Exchange 2003, are there instructions for Exchange 2003 for step for
for this document:

Answer #5    Answered By: Kristina Cox     Answered On: Mar 04

All the steps are given in that document. Please take a look.

Also enabled callstack and turn off custom erros to see the exact message
on the web page.

Enable CallStack and Disable CustomErrors

Locate the web.config file for the web application  in question and change
following tags as below:

Search for a tag customErrors and set  its value to "Off".
<customErrors mode="Off" />

Search for a tag CallStack and set its value to "true".
<SafeMode MaxControls="50" CallStack="false" />

Get latest ULS logs from C:\Program Files\Common Files\Microsoft Shared\web
server extensions\12\LOGS

We can find the error  there also.

Didn't find what you were looking for? Find more on Incoming email setup Or get search suggestion and latest updates.