Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

IE 7 and SharePoint

  Asked By: Evelyn    Date: Oct 07    Category: Sharepoint    Views: 691

Since IE 7 has been released, I was thinking of getting used to it before Microsoft forces on us. Did anyone notice any side effects of IE 7 with SharePoint for example CSS, JavaScript files etc.? I read few problems online with IE 7 Beta. Is it OK to upgrade the browser? Need your opinion.



6 Answers Found

Answer #1    Answered By: Jagdish Joshi     Answered On: Oct 07

I have been using it for a week now, and have noticed no bad tendencies. Matter
of fact i really like the new IE.

Answer #2    Answered By: Christop Mcfadden     Answered On: Oct 07

I've been using IE7 with MOSS2007 for almost a week, and the only issue
that I've seen is a minor security annoyance. When you install IE7,
apparently some of your browser  security settings get changed.

I've written about it on my blog, in the post titled "Login Prompt with


Overall, I like IE7 so far. Tabbed browsing, quick tabs (preview
screenshots of the pages that are open in all of the tabs), and page
rendering are nice.

Answer #3    Answered By: Victoria Bell     Answered On: Oct 07

During the IE7 betas, many pages would nag about the need to load DLLs
when browsing WSS v3 pages. I bugged the problem and it was sent to the
IE7 team to fix. Don't know if it was resolved in the RTM version or

Answer #4    Answered By: Cassidy Sharpe     Answered On: Oct 07

Just took the plunge this morning, and it seems fine so far.

Answer #5    Answered By: Linda Mason     Answered On: Oct 07

Little late to the party, but I’ve been using IE7 since the betas back in mid-summer and haven’t ever noticed anything negative in my SharePoint experience, except for a few IE7 beta-related CSS rendering issues.

Answer #6    Answered By: Hans Weiss     Answered On: Oct 07

I updated my work PC and noticed that then, every time I visited one of my SharePoint sites, I had to login again, even though I was already logged into the domain.

My security settings, from IE 6 (fully updated and patched version) to IE 7 (release version) did not change with regard to my Trusted Sites, in that all my entries made it through the IE update intact. Yet, I am was still prompted for login each time.

I discovered that a setting in IE Security was the cause:

Security Settings|Trusted Sites Zone|User Authentication was set to `Automatic Logon only in Intranet zone". I do not know if said setting is new to IE 7 or had been changed from some setting in IE 6. Regardless, I dug that the setting existed, so I simply added (moved) my SharePoint sites, from my Trusted Sites zone, over to my Intranet zone, restarted the PC (equivalent to logout and login to the domain), and all was then well.

I opted for that solution instead of altering the security setting, because I like the setting. (Why my sites are not auto-detected as being part of my intranet is another matter, albeit a minor one, that I can investigate at my leisure..probably subnet related or some such).

Didn't find what you were looking for? Find more on IE 7 and SharePoint Or get search suggestion and latest updates.