Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Home Page Not Accessible

  Asked By: Freddie    Date: Dec 02    Category: Sharepoint    Views: 1475

I was trying to grant the anonymous access to few of our inital
pages ..& some thing got misconfigure...

Today even with the administrator password, the browser is giving
this error.
===========
Error:
You cannot view this area, either because the area no longer exists,
or because you do not have the rights to view this area. To change
your rights, contact the site administrator.
===========
Can i have your suggestions.
While the subsites are OK & working Fine.
Thanks in advance.

Share: 

 

3 Answers Found

 
Answer #1    Answered By: Jose Baker     Answered On: Dec 02

U need to set anonymous  access on your portal and also on your virtual server. I think u've done it only on the virtual server using inetmgr.

I have listed an article below for your reference

Enable anonymous access  for the virtual server

1. On the taskbar, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. In Internet Information Services (IIS) Manager, click the node for the computer containing the portal site, click the node for Web Sites, and then click the virtual server.
3. On the Action menu, click Properties.
4. Click the Directory Security tab.
5. In the Authentication and access control section, click Edit.
6. On the Authentication Methods page, select Enable anonymous access, and then click OK.
7. Click OK.

After you finish these steps, you can manage anonymous access from the site  Settings page. Users can access the portal anonymously by typing http://portal:port number. To access the portal while using normal authentication, users can still access the portal by typing http://portal.

Enable Anonymous Access Without Using a Virtual Server

You can also enable anonymous access without using a virtual server. However, if you do this you lose the ability to authenticate users, so it is not recommended.

Enable anonymous access without using a virtual server

1. On the taskbar, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. In Internet Information Services (IIS) Manager, click the node for the computer containing the portal site, click the node for Web Sites, and then click Default Web Site.
3. On the Action menu, click Properties.
4. Click the Directory Security tab.
5. In the Authentication and access control section, click Edit.
6. On the Authentication Methods page, select Enable anonymous access, and then click OK.
7. Click OK.


Manage anonymous access settings

1. On the Site Settings page, in the General Settings section, click Manage security and additional settings.
2. On the Manage Security and Additional Settings page, in the Users and Permissions section, click Change anonymous access settings.
3. On the Change Anonymous Access Settings page, do one of the following:
3.1 To allow anonymous users to access areas and content on your portal site, click Areas and content.
3.2 To allow anonymous users to access areas and content on your portal site and to perform searches, click Areas, content and search.
3.3 To prevent anonymous users from accessing anything on your portal site, click Nothing.
4. Click OK.
5. Do the following on each front-end Web server that is using network load balancing:

1. On the taskbar, click Start, point to All Programs, point to Accessories, and then click Command Prompt.

2. Type iisreset and then press ENTER.

 
Answer #2    Answered By: Cornelius Guerrero     Answered On: Dec 02

I tried with the IIS & also with the Virtual Server
But..
========
1. On the Site Settings page, in the General Settings section,
click Manage security and additional settings.
2. On the Manage Security and Additional Settings page, in the
Users and Permissions section, click Change anonymous  access
settings.
=====**On the Change Anonymous access  Settings page**=======

* Anonymous Access page  => itself is not accesible now.

After repeating the above said steps... Now i am getting...
"server unavailable" on both the root & child Sites!!
with the Application pool stating... Red Cross with... unspecied
Error!!!

 
Answer #3    Answered By: Roderick Wolfe     Answered On: Dec 02

I think u r not able to see this page  because anonymous  users r not
admins. So u need to authenticate yourself into the site.

You can try doing that as mentioned below.

site  Settings page. Users can access  the portal anonymously by
typing
> http://portal:port number. To access the portal while using normal
> authentication, users can still access the portal by typing
> http://portal.

Bwt, I tried setting up SPS on a laptop and then restored to it a portal
I had created. I realized that if you are not connected to the domain
SPS does not work. It causes authentication errors.

So I was trying out anonymous access to by pass connecting to the
domain. That too was a non-starter for only the Home and News areas
were displayed but the Topics and Sites did not.

For your problem of allowing all users to view  some areas of the portal
In the Add Users page choose "Select users and groups"
This will load the "Select users and groups" dialog. select "Built-in
Accounts" in the "Find in" dropdown list. The "Results" list will be
populated with all the built in accounts. Choose "NT
Authority\Authenticated Users". And give them "Reader" permissions. If u
want them to have "MySite" feature give them "Member" permissions.

This will give everyone access to all the portal areas. In whichever
area you want to restrict access choose the "Manage Portal Site" option
in the quick launch bar. Choose "Manage Security" option in the context
menu of the relevant area. You will go to the Manage Security Settings
page. You can remove all the built in groups and add individual users
or groups as per your requirements.

Hope this was helpful to you.

 
Didn't find what you were looking for? Find more on Home Page Not Accessible Or get search suggestion and latest updates.




Tagged: