Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Getting "Web Application could not be found" error when connecting

  Asked By: Bobbi    Date: Mar 13    Category: Sharepoint    Views: 6995

I have been trying for a couple of days to run a program to migrate several
thousand documents form a thrid party vendor into a SharePoint document library.

One of the problems is that in this environment we do not have access to the
development server. So while the console application I have written to migrate
the data works fine in my Virtual PC environment, when the NetOps folks run it
on the development server, it throws this error:

"The Web application at http://site could not be found. Verify that you have
typed the URL correctly..."

The application is erring out on the following line:
site = new SPSite(ConfigurationSettings.AppSettings["SharePointSiteName"]);

I have tried using a full name and an IP address for the SharePointSiteName
value. I even had someone log into the Server using the same credentials as the
application pool for that sharepoint app. Still no luck.

So, has anyone had this problem before, or can anyone suggest steps for
troubleshooting?

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Edgardo Atkins     Answered On: Mar 13

Things to check:

1) Which server  is this actually being run  on? If you are using OM
calls are your Ops folks running it directly on the SharePoint server?

2) What user context is the console  app being run under? Certain
OM calls are going to require different levels of permissions, and those
are going to depend on the user context.

 




Tagged: