Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Getting Error when trying to start Windows SharePoint Services Sear

  Asked By: Greggory    Date: Jan 01    Category: MOSS    Views: 2955

When I try to start the Windows Sharepoint Services
Search in Sharepoint 2007 I run into this error on my
Virtual Machine:

WSS_Search_DEVSHAREPOINT02 on
np:\\.\pipe\MSSQL$Microsoft##SSEE\sql\query contains
user-defined schema. Databases must be empty before
they can be used. Delete all of the tables, stored
procedures and other objects or use a different
database.

I would like to try to empty the database, but I'm
unsure how. The closet thing to the WSS_Search file I
get is a WSS_Search_DEVSHAREPOINT02.mdf. I have tried
various Database programs but with no sucess in
opening the file. Has anyone else encountered this
problem?

Share: 

 

2 Answers Found

 
Answer #1    Answered By: Joshuah Huber     Answered On: Jan 01

Some of our SharePoint Index servers are showing the following event
in the server event log and as a result, incremental crawl did not run.
This event appears to be intermittent and unpredictable. I searched MS
site and internet and could not find much info about it. Has anyone seen
this event and know what causes it and how to fix it? THANKS!

SOURCE: Office Server Search

Category: Gatherer

Type: Warning

Event ID: 2423

The update cannot be started because all of the content sources were
excluded by crawl rules, or removed from the index configuration.

Context: Application 'SharedServices1', Catalog 'Portal_Content'

Details:

Unspecified error

(0x80004005)

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

 
Answer #2    Answered By: Ciara Collier     Answered On: Jan 01

You have several options:

First, simply specify a different WSS Search database in Central
Administration, then start  the service from Central Admin, Operations,
Services on Server

Second, you could load SQL Express Mgmt Studio on another machine,
connect to your SQL EE server, and remove the WSS_Search_DEVSHAREPOINT02
database.

The lazy way might also work ;-) - you can reset a WSS search
database/index by using 'Stsadm.exe -o spsearchdiacriticsensitive
-setstatus True -force'.

 




Tagged: