Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Forms Services: InfoPath Web Service issue

  Asked By: Norberto    Date: Jun 07    Category: Sharepoint    Views: 4495

I have an InfoPath form connecting to the SharePoint
GetUserProfileByName Web Service using .udc files stored in a
SharePoint Data Connections Library.
This works fine, when i run it in preview mode from InfoPath. When I
publish to form lib I get

An error occurred accessing a data source.

An entry has been added to the Windows event log of the server.
Log ID:5566

I have read a dozen or so blog posts on how to fix this:
I have tried:


Disable loopback via:


Didn't work still get LogID: 5566

2. Created a UDC, and added auth section:

<udc:UseExplicit CredentialType="NTLM">

Didn't work still get LogID: 5566

If I need to use SSO, does anyone have refernce on how to set SSO up
and then what to put in for authentication?

If anyone has gotten this to work, how did you solve it? What UDC
auth method did you use and did you use SSO?

For my environment it is a 2 server: 1 for sql, 1 for everything
else: WFE, App, etc, so I'm hoping Kerberos isn't needed? I am only
needing to call the 1 out of the box web service using the no code



4 Answers Found

Answer #1    Answered By: Daniella Landry     Answered On: Jun 07

It's been a while (read: two years), and I used a custom web  service that we
wrote to hit AD as necessary, but I remember that we needed a Full Trust
form (which I'm sure you've already done).

Also, what happens if you enable anonymous access on the IIS site that
supplies this service? If it works  after that, you'd have a better idea of
whether authentication is the issue.

Answer #2    Answered By: Bo Stafford     Answered On: Jun 07

I am using Data Connections to connect to web  service, so i don't think it
needs to be full trust? I am not using any managed code in my form  either.
I tried setting anon in IIS and still get same error:

The following query failed: GetUserProfileByName (User: mydomain\myuser,
Form Name: Expense Report , IP: , Request:

The remote server  returned an error: (401) Unauthorized.)

Answer #3    Answered By: Jocelyn Shelton     Answered On: Jun 07

Can you call the service  manually from the browser?

Answer #4    Answered By: Joey Soto     Answered On: Jun 07

yes, it loads in the browser...............

Didn't find what you were looking for? Find more on Forms Services: InfoPath Web Service issue Or get search suggestion and latest updates.