MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Forms Authentication not authenticating

  Asked By: Charan    Date: Feb 01    Category: MOSS    Views: 1200

I have a plain old MOSS 2007 site collection and the client wants Forms Auth
enabled. I created a SQL Membership provider (along with the appropriate
connection string) in web.config, tested the connection string, connected to
it via Visual Studio (from my own machine) and created a couple of roles and
users with the built-in ASP.NET membership site, and then turned on FBA for
the application. I get the sign-in form at /_layouts/login.aspx as
expected, but when I provide credentials and hit the button, I get...
nothing. The blank page login comes back up and there's not even an error

We've been going around in circles for a little while here, and I feel like
there's something obvious I'm missing. Any suggestions?



14 Answers Found

Answer #1    Answered By: Leeann Hull     Answered On: Feb 01

You didn't mention adding an FBA user to the site collection as a Site
Collection Owner. Even if users authenticate, you need to authorize them by
giving them permissions to the site. That normally results in an error page
about access denied, so I don't know why that isn't coming up. But its one
thing to check.

Answer #2    Answered By: Vaasu Radhakrishna     Answered On: Feb 01

I tried adding a Site Collection Owner, but People Picker wouldn't recognize
any of my users (The Dreaded Red Squiggly Line).

Answer #3    Answered By: Brinda Bca     Answered On: Feb 01

Did you add the Membership provider and connection string settings to both
the site collection web app and the CA web app? Not putting it in the CA
web app is normally why you can't add a new site collection owner from the
FBA. That or a PermissionPolicy at the web app level is required or you
won't be able to login.

Answer #4    Answered By: Sheryl Velez     Answered On: Feb 01

Yep, they're in there. The weird thing now is that I can add SCAs through
Central Admin, but when I go to the FBA site collection, I'm getting the
login page... even though I've told it to allow anonymous. Whether I
provide it with real credentials or fake, I get no success and no error

Funny story: I went through the whole process again on my local dev server,
and FBA started working like a champ. It even brought me anonymously to the
portal home page, and then allowed me to sign in as a Sql membership user.

So now I'm wondering what could possibly be wrong with this server, since
the same parameters worked on my dev box. I even copied the web.config
verbatim to the offending site collection, but no change.

Answer #5    Answered By: Alexandra Lewis     Answered On: Feb 01

Do you by any chance have cookies disabled in IE on your laptop? That would
do it.

Answer #6    Answered By: Himanta Barthakur     Answered On: Feb 01

my dev server FBA authenticated me with no problems.

In fact, I had added the URL of the test site to the Local Intranet zone as
well, just to make sure I was treating the environments the same way.

Answer #7    Answered By: Mansi Revenkar     Answered On: Feb 01

Oh, and yes, I did add the membership provider to the CA web.config before
doing that (assuming you meant for me to use CA when adding that SCO).

Answer #8    Answered By: Lizette Mcconnell     Answered On: Feb 01

If the membershipProvider information was added to the CA web.config before
you tried to add the site owner then there is either something wrong with
the configuration entries you added or something wrong with the custom
membership provider. If the membership provider configuration is correct
and working you should be able to lookup users from CA. The problem is
either in the web.config or the membership provider itself if you can't.
Assuming it works in a regular ASP.net app then I would double check where
you put your entries in the SharePoint web.configs and also what access the
application pool identity account has to the sql database being used for
membership (assuming you are using integrated security).

Answer #9    Answered By: Rosanna Parrish     Answered On: Feb 01

The provider appears to be working. I pulled the web.config entries for the
connection string and provider, and inserted them into a local
VS.NETwebsite project. The provider was listed as expected, and I was
able to
open the Membership config site and add users and roles.

This leaves the web.config. Sounds like I need a giant magnet to pull that
needle out of the haystack, eh?

BTW, I'm using SQL auth with an account known to be working (as demonstrated
in the test ASP.NET app).

Answer #10    Answered By: Kalash Karmakar     Answered On: Feb 01

It may sound silly, but few years back I had some problem with the anonymous
authentication and I found some file or folder permissions missing from some
files in the layouts directory.

Answer #11    Answered By: Mauricio Tanner     Answered On: Feb 01

Okay, I've gotten past that problem and now access is denied when I use bad
credentials :) The problem is, I don't get an error with good credentials,
but I don't get in either! When I try to switch to that application in
Central Admin, I get a login prompt... and no existing credentials work.

I feel like I'm chasing myself through a four-dimensional house. Any
helpful hints?

Answer #12    Answered By: Gina Freeman     Answered On: Feb 01

The latest: I managed to get Central Administration working again by
specifying the correct default role provider (namely
AspNetWindowsTokenRoleProvider) in the CA web.config roles section.

NOW, Central Admin will let me choose users from my membership DB as Site
Collection Admins... however, I'm back to "no success, no error" when I
attempt to log in to the Forms Auth site collection in question (which, as
far as I can tell, has all the necessary stuff in web.config).

There has to be some silly thing I'm missing, but for the life of me, I
still can't figure out what it is. If CA can see your membership provider,
but that same provider isn't available from the app you're trying to
protect... what the heck?

Answer #13    Answered By: Tyrell Nash     Answered On: Feb 01

Could you send me a copy of the Web App's Web.config from the site that
isn't authenticating? I'll take a look and let you know if something seems
out of place.

Didn't find what you were looking for? Find more on Forms Authentication not authenticating Or get search suggestion and latest updates.