Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Force upgrading existing wss sites to asp.net 2.0 on sbs 2003

  Asked By: Palak    Date: May 18    Category: Sharepoint    Views: 1386

I have researched the stsadmin.exe tool to force upgrade my current wss
sites to asp.net 2.0.
I want to begin preparing for sharepoint 3 when it is out of beta and
we'll upgrade our office package then.
Everything is in place for all of the prerequisites and I've toyed
around a bit in sharepoint designer beta and it all looks very
promising and very nice. (despite that I can't use it on framework
1.xxx)

Anyway, the doc says I must be an admin on the local server box to run
stsadmin.exe

I am an admin on a lan and tried to run it via terminal server admin
connection from a pc, which is connected directly to the same router.
It looks like I can use the commands inside the lan and I wondered if
I'm just messing up the site url or command or something else.
I'm not terribly familiar with "how to" using stsadmin.exe and some of
it is kind of vague to me in the administrators guide.

Here's as far as I've gotten so far, can I get some clarification
please?

http://www.whitcombpalace.com/Code/Image1.jpg

Share: 

 

11 Answers Found

 
Answer #1    Answered By: Donta Kirkland     Answered On: May 18

At the cmd prompt change directories to c:\program files\common files\microsoft
shared\web server extensions\60\bin then run stsadm -o ...... form that
location.

 
Answer #2    Answered By: Cade Velazquez     Answered On: May 18

how exactly do I change the directory from C:\documents and
settings\administrator\
to C:\program files\common files\ etc etc...
I cant backspace it out or anything and if I paste it in it gives:
"there is no such command as C:\program files" etc... :|
Sorry for the noob stuff, but this is where I'm lost.

 
Answer #3    Answered By: Ariana Christensen     Answered On: May 18

Click on the Start button in the lower left of your desktop andthen click opn
Run. enter CMD andclick ok. The type the following lines follwoed by the enter
key: [ <-|]

c: [<-|]
cd program files\common files\Microsoft Shared\web server extensions\60\bin
[<-|]

 
Answer #4    Answered By: Darrius Whitfield     Answered On: May 18

For some reason, it is requiring you to enclose the entire command
in quotes; it could have something to do with Terminal Services. It
should read the entire line, spaces included, and try to execute
everything up to the enter key.

You can do one of two things: Change Directory (CD), while enclosing
the directory path in double quotes, to the bin directory and run
stsadmin or enclose the command in double quotes. I am not sure how
the Yahoo! Group engine will treat double quotes so these next lines
may not show up right:

C:
cd "program files\common files\Microsoft Shared\web server
extensions\60\bin"
stsadmin –o upgrade -forceupgrade –url http://whitcombpalace.com" target="_blank" rel="nofollow">http://whitcombpalace.com

-or-

"C:\program files\common files\Microsoft Shared\web server
extensions\60\bin\stsadmin" –o upgrade -forceupgrade –url
http://whitcombpalace.com" target="_blank" rel="nofollow">http://whitcombpalace.com

The long command is all one line.

 
Answer #5    Answered By: Adrienne Greene     Answered On: May 18

Here's the scoop on how to do it snipped from Biztalk 2006, look down and
compare this to the force  upgrade in the administrators guide.

This method worked like a charm.

Now I have only one puzzle to solve. The "Default Web Site", (just the web
server login page) won't force upgrade like the rest of them for some reason
and thus won't render out, but really we all just use RDC anyway and don't
connect to the servers via I.E. 6.

The websites themselves were the big issue and now I can maybe look at wss
beta 3 and Sharepoint Designer beta. Woot! New toys!

Thanks a lot for your ideas and help, maybe this can shed light on anyone
else running into problems too.

 
Answer #6    Answered By: Joshuah Huber     Answered On: May 18

I got the directory to change over
okay, but still receiving a command line error.
Can you maybe take a peak?
http://www.whitcombpalace.com/Code/Image2.jpg

"Force" for force  upgrade is not listed in the stsadm.exe commands at
least on this list...

 
Answer #7    Answered By: Ciara Collier     Answered On: May 18

What Specific error are you gettting??

 
Answer #8    Answered By: Keenan Whitehead     Answered On: May 18

You can see for yourself on the link. I took a screen capture.

At first I thought it was because I was logged in via Terminal Server as the
Admin, but I don't believe that's it now.

http://www.whitcomb <http://www.whitcombpalace.com/Code/Image2.jpg>
palace.com/Code/Image2.jpg

Save the pic and blow it up a bit if you need to, the resolution is good.

 
Answer #9    Answered By: Trisha Wheeler     Answered On: May 18

Have you tried logging on the server using the server account?

 
Answer #10    Answered By: Dameon Dejesus     Answered On: May 18

I guess when the Administrators guide says you must be
logged into the box itself they're not kidding.
It's a little irritating cause I have to strip down another machine and
put up a monitor and all of that, but no biggy. The servers are tucked
away in a semi-sealed closet (no monitor, keyboard, mouse or place to
put them) to keep dust and other stuff off them etc... I work in drug
testing and our little place can get kinda messy quick.
Thanks for your help, I'm pretty sure I can do it, just have to sit
indian style on the floor for a bit.

 
Answer #11    Answered By: Tejaswani Barve     Answered On: May 18

I did not mean to physically logon. We logon using remote desktop all of the
time to manage our servers. I meant to use Configuration Database Adminstration
Account.

 




Tagged: