Sharepoint 2010 Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint 2010       RSS Feeds

First time open Excel/PPT file from SharePoint folder is read-only

  Asked By: Yan    Date: Jul 24    Category: Sharepoint 2010    Views: 7210

This issue only happens to a few client PCs, not all of client PCs. And I think this should be related to client PC's configuration/setting. WHoever logins to the PC gets the same exact issue.

We have an application which uploads files to SharePoint folders. The first Excel or PowerPoint file from SP folder are read-only and cannot be edited. The second file and afterwards are able to edit/save without any issue. I have tried many things and facts/results are as follows:

1) Monitored Content.MSO and all files are removed correctly after closed;
2) This issue only happens to the first XlSX/PPT file under SP folder. The second file or following will not have the issue;
3) There is a temperary file created under one of folders under Content.IE5. When the issue happen (the excel file is read-only), I can still edit the temperary file under Content.IE5 (add new row etc.) and save successfully. But for the second file under SP folder, I cannot edit Temperary file under Content.IE5 (locked by another name). Looks like when issue happens, the excel file is not really tie to the temperary file folder;
4) I tried to uninstall IE8 and re-installed IE8 (turn off from Microsoft then turn on), no difference;
5) I checked OWSSUPP.DLL and only one found under office14;
6) I tried deleting all files under Content.IE5 and Content.MSO, no difference;
7) Once the first file is opened and closed without saving (read-only, not able to save), next time the file is able to edit (there will be Edit Workbook button and Read-only on top of screen (read-only from server);
8) I tried Paul Liebrand's methods and could not find an entry called CacheFolderID from register. Here is Paul's solution:

I have struggled with the issue for a few days and seems could not find a reason.

Thanks a lot.



No Answers Found. Be the First, To Post Answer.