Logo 
Search:

Sharepoint Forum

Ask Question   UnAnswered
Home » Forum » Sharepoint       RSS Feeds

Firefox and flyout menus (top navigation)

  Asked By: Jamie    Date: Apr 28    Category: Sharepoint    Views: 2722

I am trying to find some CSS properties to allow the cascading flyouts
along the top navigation of our sharepoint site to flyout "on top" of
other elements on the page. This would fix an issue we have with our
Firefox users.

For example - if a pdf is loaded inline - then a longer cascading
flyout loads partially "behind" the pdf element on the page.

Any advice?

Share: 

 

5 Answers Found

 
Answer #1    Answered By: Rosemarie Cervantes     Answered On: Apr 28

Flyouts are enabled by modifying the properties  of either the ASPMENU,
SiteMapDataSource, or SiteMapProvider objects. The ASPMENU and
SiteMapDataSource for the TopNavBar are on the masterpage of the site
and the SiteMapProvider is in the Web.CONFIG. For most sites resetting
the properties of the ASPMENU control are enough. But for
non-publishing sites you will probably need to modify the
sitemapdatasource and Sitemapprovider definitions also.

 
Answer #2    Answered By: Manan Kadu     Answered On: Apr 28

Thanks for the quick response. We do haave the flyouts enabled - our
issue is that for Firefox, the flyouts load "behind" inline  objects on
the page. They work fine in IE however - we do not control the user
base - thus we have about 18% Firefox.

Have you or anyone dealt with this? Are there some css  attributes
that can be set to pull this menu layer back up on top  of any inline
objects (PDF, etc.) as it does in IE?

 
Answer #3    Answered By: Tonia Franco     Answered On: Apr 28

We had that happen once before, yes. I think CSS has something like a Z
dimension and if it isn't explicitly specified, Firefox obeys the order
that the elements  appear in. When we did it, we had declared the ASP
flyout menus  before the body, and so body elements appeared partially
above the menus when they flew out.

 
Answer #4    Answered By: Amareswar Karkera     Answered On: Apr 28

Sounds right. It's probably that you need to set z-index: in your
theme's CSS file to a higher number (try 400, or some absurdly high
number like that).

 
Answer #5    Answered By: Cheyenne Jacobson     Answered On: Apr 28

The problem is a combination of css  z-index, and a Firefox/Flash issue
that gives Flash objects an infinite z-index. Google around for "flash
z-index" and the like and you'll come across a multitude of
discussions and blog posts with various attempts to fix  the problem.
Typically it involves adding a w-mode property to the Flash element
which switches on z-index awareness. Then you set the z-index of the
Flash element  to something lower than the z-index of the flyout  menus.
(And trust me, if that works it's a LOT nicer than the old hack of
using javascript to detect the flyout mouseover and instantly replace
the flash element with a static image of the flash item.)

 
Didn't find what you were looking for? Find more on Firefox and flyout menus (top navigation) Or get search suggestion and latest updates.




Tagged: