MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

FIM just broke, crappy error message

  Date: May 29    Category: MOSS    Views: 1474

So trying to get the UPS to work for the last week or so. Everything started
going well, and then bang:
The server encountered an unexpected error and stopped.

"BAIL: MMS(6580): storeimp.cpp(234): 0x80004005 (Unspecified error)
ERR: MMS(6580): server.cpp(373): Failed to connect to the database User Profile
Service Application_SyncDB_87e62de886e04637a61a5b979bdb051a on ccp_spsql
BAIL: MMS(6580): server.cpp(374): 0x80004005 (Unspecified error)
BAIL: MMS(6580): server.cpp(3860): 0x80004005 (Unspecified erNoror)
BAIL: MMS(6580): service.cpp(1531): 0x80004005 (Unspecified error)
ERR: MMS(6580): service.cpp(980): Error creating com objects. Error code:
-2147467259. This is retry number 0.
BAIL: MMS(6580): clrhost.cpp(224): 0x80131022
BAIL: MMS(6580): scriptmanagerimpl.cpp(7670): 0x80131022
BAIL: MMS(6580): server.cpp(251): 0x80131022
BAIL: MMS(6580): server.cpp(3860): 0x80131022
BAIL: MMS(6580): service.cpp(1531): 0x80131022
ERR: MMS(6580): service.cpp(980): Error creating com objects. Error code:
-2146234334. This is retry number 1.

This happened when I tried to run a sync from the FIM client. Now the service is
down and will not come back up. Google and bing return nothing.

Any help at all would be great!



5 Answers Found

Answer #1    Answered On: May 29    

FIM is fun. Totally feel your pain. Look for DCOM errors in your system
logs, there are some really messed up DCOM issues I had on a Server 2008 R2
farm. This will cause it. Also registry ACLs. If you have changed the port of
your CA then you will need to do some tweaks too.

Took me a couple days to straighten out our issues.

Answer #2    Answered On: May 29    

though in a lot of cases errors like this can be fixed by going into Services
on Server in Central Admin and doing a stop/start on the FIM Sync service. What
that does behind the scenes is unprovision and reprovision the services.

Answer #3    Answered On: May 29    

Yep, tried that, this sucker is busted.

Answer #4    Answered On: May 29    

I’d first try a psconfig.exe –cmd secureresources.

Next, I’d check the SharePoint Server 2010/CU level for issues (if using
client aliasing)

Next, I’d check the DB permissions and verify a DBA didn’t change them.

Maybe these help point you in the right direction.

Answer #5    Answered On: May 29    

UPS also REQUIRES local administrator privileges for the setup phase. Make sure
you have the UPS account included in the local administrators group while
setting up, then remove it when done with setup.

The error makes it appear that the account you're using for UPS needs to have
access to the SQL DB "Application_SyncDB_87e62de886e04637a61a5b979bdb051a".
Verify that is so...

Didn't find what you were looking for? Find more on FIM just broke, crappy error message Or get search suggestion and latest updates.