Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Failure decompressing data from a cabinet file

  Asked By: Tapasvi    Date: Jan 01    Category: MOSS    Views: 4035

When I try to save a Picture Library in MOSS 2007 as a template with content it gives me the error "Failure decompressing data from a cabinet file at Microsoft.SharePoint.Library.SPRequestInternalClass.SaveListAsTemplate(String bstrUrl, String bstrListName, String bstrTemplateName, String bstrTemplateTitle, String bstrDescription, Boolean bSaveData)
at Microsoft.SharePoint.Library.SPRequest.SaveListAsTemplate(String bstrUrl, String bstrListName, String bstrTemplateName, String bstrTemplateTitle, String bstrDescription, Boolean bSaveData) "

I increased the current template-document-size to the max- limit of 500 MB on the SharePoint Server.

However, it gave the same error.

I did some R & D by creating templates with content from Picture Library with varying sizes from less that 10 MB to 25 MB and above.

For some cases, it failed and some cases it worked.

I tried to find out if it was due to a particular image file or due to some size constraint.

Each time it worked in an unpredictable fashion.
e.g. If I assume 10 MB (default size) as the limit, it worked for picture library sizes greater than 10MB.
If I assumed 25 MB as the limit, it worked for some picture libraries sizes greater than 25MB and failed for others above or below 25 MB.

I could not come to any of the below logical conclusions :
1. The image file was the reason for the error.
2. A particular size limit was the reason for the error.

This problem is similar to the problem of saving a site as a site template with content, that has already been mentioned by many on the web, but without a solution(the stsadm solution of increasing the template size as suggested by many does not work).

So, in case if any of you come across this problem and find a solution or if any of you that have already found a solution or workaround, please let me know.

Share: 

 

3 Answers Found

 
Answer #1    Answered By: Jessi Sweet     Answered On: Jan 01

When I try to save  a picture  Library in MOSS 2007 as a template with content it gives me the error "Failure decompressing data  from a cabinet file  at Microsoft.SharePoint.Library.SPRequestInternalClass.SaveListAsTemplate(String bstrUrl, String bstrListName, String bstrTemplateName, String bstrTemplateTitle, String bstrDescription, Boolean bSaveData)
at Microsoft.SharePoint.Library.SPRequest.SaveListAsTemplate(String bstrUrl, String bstrListName, String bstrTemplateName, String bstrTemplateTitle, String bstrDescription, Boolean bSaveData) "

I increased the current template-document-size to the max- limit of 500 MB on the SharePoint Server.

However, it gave the same error.

I did some R & D by creating templates with content from Picture library  with varying sizes from less that 10 MB to 25 MB and above.

For some cases, it failed and some cases it worked.

I tried to find out if it was due to a particular image file or due to some size constraint.

Each time it worked in an unpredictable fashion.
e.g. If I assume 10 MB (default size) as the limit, it worked for picture library sizes greater than 10MB.
If I assumed 25 MB as the limit, it worked for some picture libraries sizes greater than 25MB and failed for others above or below 25 MB.

I could not come to any of the below logical conclusions :
1. The image file was the reason for the error.
2. A particular size limit was the reason for the error.

This problem is similar to the problem of saving a site as a site template with content, that has already been mentioned by many on the web, but without a solution(the stsadm solution of increasing the template size as suggested by many does not work).

So, in case if any of you come across this problem and find a solution or if any of you that have already found a solution or workaround, please let me know.

 
Answer #2    Answered By: Kelvin Mckinney     Answered On: Jan 01

I tried using manage content and structure, but it required the Publishing feature to be enabled for the web site. I tried to do that from the SharePoint Web Interface, it gave me an error. I tried it using stsadm, I had to have a PublishingPrerequisites feature enabled. I did that but then when I tried to enable the Publishing feature it gave me an error. Can you shed more light on the content deployment you mentioned?

 
Didn't find what you were looking for? Find more on Failure decompressing data from a cabinet file Or get search suggestion and latest updates.




Tagged: