Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

External URLs are invalid

  Asked By: Deborah    Date: Dec 28    Category: MOSS    Views: 1791

I have finally gotten my test VM of MOSS2007 up and our MCMS content
migrated over for testing. My first error is when I am testing the
editor, and it states that 'field does not allow external URLs'. I even
tried coding it into the HTML, but that didn't work either. Before I
dig too deep, thought I would check with you all for guidance. Am I
using the wrong toolbsr item (Insert hyperlink) or do I have to check
something
with our setup to allow external links?

Share: 

 

6 Answers Found

 
Answer #1    Answered By: Randall Hunt     Answered On: Dec 28

I believe what you are trying to do is created an External URL zone for
your SharePoint site. You can do this through Alternate Access Mappings
inside of Central Administration/Operations/Global Configuration/Edit
Public URLs and choose the Alternate Access Mapping Collection for that
application. You will need to first Extend the web application to that
public URL by going through Central Administration/Application
Management/Create or extend Web application/Extend an existing Web
application.

 
Answer #2    Answered By: Joe Hart     Answered On: Dec 28

Sorry I wasn't clearer in my post. I am simply trying to make a link
on a page go to a URL outside of our sharepoint site (say
www.google.com for instance). Will your solution enable that option?

 
Answer #3    Answered By: Jorge Cole     Answered On: Dec 28

There are several ways that you can make links  on a SharePoint page that host
External URLs.

Many of the site definitions create a Link List and put the web part from that
list on the default page of the site. To add a link simply click on the Add a
Link hyperlink  in the webpart and supply the URL (make sure its prefaced with
the appropriate http:// or https://) and a description of the link.

Or you can add a link to the Top Link Bar (Global) or the Quick Launch(Current)
menu through the Navigation link on the site settings page of a publishing site.
Again simply supply the URL and description.

You can also do the same thing on a non-publishing site, but I forget the name
of the link on the site settings page.

Could you be a little clearer on where you are trying to add the link? And are
you sure you are hard coding  the http://? Otherwise it will take it as a
relative reference, which of course can't be external.

 
Answer #4    Answered By: Rodolfo Tate     Answered On: Dec 28

I think that this may be caused by my migrating our MCMS content to
MOSS? On a converted page, I am trying to insert  an external
hyperlink inline (ensured I was using full URL such as
http://www.google.com) the error  is: 'This field  does not allow
external URLs'
I tried the same thing by creating a new page and it works fine.

Then I tried it on an internal page, that was migrated but used a
different template than the page I got the error on and it worked.
So I guess my next question might be, how do I tell what kind
of 'field' it converted to? Maybe I need to change this page to use a
different one?

 
Answer #5    Answered By: Jesus Foster     Answered On: Dec 28

I opened the page layout in SP Designer. The migrated content was in a
PublishingWebControls:RichHtmlField with an attribute of
AllowExternalUrls=False. Changing this to true (duh) allows me to add
external URLs.
So NOW my question is: Is there another way to change this attribute,
or did I do it the 'right way'?

 
Answer #6    Answered By: Alfredo May     Answered On: Dec 28

It is clearer now. You can also add a Google web part by following the
directions listed here:

www.amazines.com/.../412729?art
icleid=412729

You will need to download and execute the GoogleSearchWebParts.zip (1.10
mb)
<www.sharepoint-blogs.com/file.axd
that is available near the bottom of this article onto your SharePoint
server. This will make the webparts available in your Web Parts list.

 
Didn't find what you were looking for? Find more on External URLs are invalid Or get search suggestion and latest updates.




Tagged: