Logo 
Search:

MOSS Forum

Ask Question   UnAnswered
Home » Forum » MOSS       RSS Feeds

Exchange RPC/HTTPS no longer working after Sharepoint Services Install

  Asked By: Pallavi    Date: Feb 21    Category: MOSS    Views: 1278

I am running Exchange 03 and MOSS 07. I am currently unable to
connect to exchange through RPC. I have searched all search engines
and no one appears to have a solution to this issue other than to
create another domain name. That would be a last resort solution.
Does anyone have any suggestions on how to get this working?

Share: 

 

4 Answers Found

 
Answer #1    Answered By: Jaime Sims     Answered On: Feb 21

Was it on the same server? It could have changed the ports in the
registry. If it was on the same server, look for the articles on
installing RPC/HTTPS on a domain  controller. It lists the ports and how
to change them in the reg.

 
Answer #2    Answered By: Ashley Robbins     Answered On: Feb 21

Exchange RPC/HTTP, when you installed it, will have been installed to the
default site and using the default URL

Lets call it exchange.mycompany.com

You then installed WSS

WSS would not have stopped it working  UNTIL you extended a web application

If you extend the default web application then all requests to the root of that
application will be captured by WSS and treated as though its a request for that
site.

i.e. you cannot extend the site running  exchange.mycompany.com

So, how to fix it

Unextend the application - create a new virtual server in IIS and extend your
site to that

The original, default, virtual server / web application will then look after
exchange and RPC / HTTP and the other virtual server / web application will look
after the site

You're site will need a URL other than exchange.mycompany,com and you will need
to sue host headers to direct the traffic.

 
Answer #3    Answered By: Kelly Fowler     Answered On: Feb 21

If you want an alternative post though, where they say it's not possible to do
this, and he is a MOSS MVP, go to http://suguk.org/forums/thread/7048.aspx

If you think its just not possible you may want to just try and roll it back - I
can see that swapping the SMTP service would prevent SMTP used for incoming
mails to MOSS unless you went for the advanced settings and put the drop folder
somewhere else so I still think its possible but, hey ho.

 
Answer #4    Answered By: Fabian Gross     Answered On: Feb 21

Was able to get this working  by creating a virtual folder and putting
the exchange.dll in its own virtual folder.